주요 콘텐츠로 건너뛰기
도움말

현재 버전 게시자: Jeremy Carter ,

제목:

Faulty Vibrator and Proximity Sensor?

텍스트:

Hello everybody!
I have a customer whose iPhone 5s I initially started fixing two weeks ago for a cracked screen. Before fixing it, I tested everything before I started working on it and everything worked. I had forgotten to unplug the battery when disconnecting the LCD, but had unplugged the battery before plugging it back in. I swapped out the broken part; I put the LCD in place and powered the phone on, only to be hit with my heart sinking to the bottom of my stomach as I could see that the LCD was defective. This was my last LCD until my next order came in. I felt bad about the situation and told the customer that I would put the cracked LCD back on his phone. I verified that everything worked and all was good, except for the old cracked glass. :(
When I worked on the phone the second time, I made sure the battery was disconnected. I got everything swapped out and back in place. After replacing the glass, I tested everything and everything worked great! Although I forgot to check the vibrator motor. Even the proximity sensor worked.
The next day he informed me that his proximity sensor was no longer working, nor was his vibrator, which he says that he uses almost ALWAYS. I checked all of the settings for the vibrator, but nothing was showing that it was turned off. I told him that I would check into both issues to see what could be the cause.
I found on some message boards that bumping the phone hard against the palm of your hand can dislodge the motor from being stuck and allow it to start spinning again and others attested to that as a working fix. I thought that I would give it a try, but to no avail, even after bumping it hard a few times.
I then told him that I would replace the motor and the proximity sensor. I took the old motor out, cleaned the contacts with an alcohol prep pad, replaced with a new motor, and blew out any dust in the phone. I turned the phone on and put it in silent mode and the vibrator gave two pathetic turns and that was that. I haven't been able to get it to do anything since then. It wouldn't buzz at all with making a custom vibrate tone, or taking it out of silent mode and putting it back in silent mode.
What I don't understand is that I was never anywhere NEAR the vibrator motor with tools when I replaced the LCD or proximity sensor for first time I was inside the phone. The only thing that I can think of that would have been a problem is that I didn't unplug the battery when disconnecting the digitizer and other cables the first time I worked on the customer’s phone. Do you have any idea what would be causing this? Have you experienced this at all?
This morning the customer was checking the phone out and now his proximity sensor has FAILED AGAIN. UGH! I checked to see if worked 3-4 times while calling myself last night and each time the display went off. Now this morning it wants to stay on. He also was able to get the vibrator to buzz, but NOT consistently, nor with as much oomph as it had before. He said that it will only buzz when he receives an email or occasionally when a text comes in. I'm at my whit’s end on this. The only thing that I can think of is there being a short on the logic board from me not unplugging the battery the first time I worked on the phone.
I talked with the customer again this afternoon to ask him about the first time I opened the phone. I asked him if the vibrator motor and proximity sensor worked fine until I replaced the LCD the second time I opened the phone. He said that to the best of his knowledge everything worked like a charm until the new LCD was put in. Just for giggles, this just makes me want to throw his cracked LCD back in the phone just to see if everything will work again. UGH!
Any help or thoughts would be greatly appreciated! Thanks for your time!
Sincerely,
Jeremy
+
+P.S.
+During all repairs I'm grounded, use anti-static mats for the devices to sit on, and I wear vinyl gloves to keep from causing any additional issues, and I use ESD tools.

기기:

iPhone 5s

현황:

open

원문 게시자: Jeremy Carter ,

제목:

Faulty Vibrator and Proximity Sensor?

텍스트:

Hello everybody!

I have a customer whose iPhone 5s I initially started fixing two weeks ago for a cracked screen. Before fixing it, I tested everything before I started working on it and everything worked. I had forgotten to unplug the battery when disconnecting the LCD, but had unplugged the battery before plugging it back in. I swapped out the broken part; I put the LCD in place and powered the phone on, only to be hit with my heart sinking to the bottom of my stomach as I could see that the LCD was defective. This was my last LCD until my next order came in. I felt bad about the situation and told the customer that I would put the cracked LCD back on his phone. I verified that everything worked and all was good, except for the old cracked glass. :(

When I worked on the phone the second time, I made sure the battery was disconnected. I got everything swapped out and back in place. After replacing the glass, I tested everything and everything worked great! Although I forgot to check the vibrator motor. Even the proximity sensor worked.

The next day he informed me that his proximity sensor was no longer working, nor was his vibrator, which he says that he uses almost ALWAYS. I checked all of the settings for the vibrator, but nothing was showing that it was turned off.  I told him that I would check into both issues to see what could be the cause.

I found on some message boards that bumping the phone hard against the palm of your hand can dislodge the motor from being stuck and allow it to start spinning again and others attested to that as a working fix. I thought that I would give it a try, but to no avail, even after bumping it hard a few times.

I then told him that I would replace the motor and the proximity sensor. I took the old motor out, cleaned the contacts with an alcohol prep pad, replaced with a new motor, and blew out any dust in the phone. I turned the phone on and put it in silent mode and the vibrator gave two pathetic turns and that was that. I haven't been able to get it to do anything since then. It wouldn't buzz at all with making a custom vibrate tone, or taking it out of silent mode and putting it back in silent mode.

What I don't understand is that I was never anywhere NEAR the vibrator motor with tools when I replaced the LCD or proximity sensor for first time I was inside the phone. The only thing that I can think of that would have been a problem is that I didn't unplug the battery when disconnecting the digitizer and other cables the first time I worked on the customer’s phone. Do you have any idea what would be causing this? Have you experienced this at all?

This morning the customer was checking the phone out and now his proximity sensor has FAILED AGAIN. UGH! I checked to see if worked 3-4 times while calling myself last night and each time the display went off. Now this morning it wants to stay on. He also was able to get the vibrator to buzz, but NOT consistently, nor with as much oomph as it had before. He said that it will only buzz when he receives an email or occasionally when a text comes in. I'm at my whit’s end on this. The only thing that I can think of is there being a short on the logic board from me not unplugging the battery the first time I worked on the phone.

I talked with the customer again this afternoon to ask him about the first time I opened the phone. I asked him if the vibrator motor and proximity sensor worked fine until I replaced the LCD the second time I opened the phone. He said that to the best of his knowledge everything worked like a charm until the new LCD was put in. Just for giggles, this just makes me want to throw his cracked LCD back in the phone just to see if everything will work again. UGH!

Any help or thoughts would be greatly appreciated! Thanks for your time!

Sincerely,

Jeremy

기기:

iPhone 5s

현황:

open