주요 콘텐츠로 건너뛰기
도움말

원문 게시자: Anil ,

본문:

Hi,

I have the similar problem. I tried to replace the home button by following ifixit procedure and after replacing the home button and connecting things back in place and restarting i observed that its not detecting the SIM well :(. It took some 10days to figure it out.

So, for checking the sim issue, initially i didnt remove battery and had display power on.

Removed the back plate and I tried to press few things on back and see if there is a sim detection. I tried to see if i have any loose screws but all are fine.

I tried setting the date and time to latest and still saw the issue. The blue inductor near the battery connector is fine. So, i am looking what else can be done.

While trying this, I tried pressing the motherboard with little pressure and i see that sim doesnt get detected. When i release it tries to detect and fails showing NO SIM again. Then i tried to loose the screw at middle of mother board [guide|3144|Step 16|stepid=15383] and [guide|3144|Step 8|stepid=15374] i started seeing that sim got detected and phone is trying to acquire signal. So, it seems if we clamp the motherboard tightly the issue is occuring. I managed to fix the screw in such a position so that my sim gets detected and finally i closed the panel.

After few days, i was needed to change the sim and when i inserted another sim, i see that that sim is not geting detected. Same problem again!!. I tried with some other sim, again that too is not getting detected. But if i keep my old sim, its able to detect.

I tried to tight/loosen the screws again for the new sim. Now it works for new sim but not for old sim. I tried some 10-20 times loosing one screw, tightening other. But one is matching for one sim and not for other sims.

I got frustrated but one fine day again, i sat to try repairing again. But i already knew my problem is due to screws and pressure on mother board. So, i thought i will keep something below the mother board so that it wont get pressed. I removed almost al the screws, battery and speaker etc. I took small peices of papers, folded them so that they will have some width and inserted behind the sim tray, under mother board. Now mother board is little higher than base. I have reconnected all the screws, not too tight though and placed the back panel and after switching on the phone, i need to set date and time since its got lost whle removing battery, and then i see that the new sim got detected. Hurray!!.. I tried with one other sim, it got detected. I tried with old sim it got detected :) :).

I am not sure why on applying pressure on mother board or tightening the screws is causing the phone to not detect the sim. I am not sure if due to papers behind the sim tray helped me or due to screw loosing, but the reason for sure is some interference with inductor or what ever. May be you can try the same procedure and see if that can help.

현황:

open