주요 콘텐츠로 건너뛰기
도움말

현재 버전 게시자: Kris Rodriguez (투표 내용) ,

제목:

Multiple MagSafe Board Failures

텍스트:

Hi all.

I have a MacBook Pro 15" Unibody mid-2012.  I have two 85w power supplies that I use interchangeably.  One stays at my desk at home and the other travels with me.

While using the 'travel' charger the other day, I heard a pop (I think from the charger/brick) and the charging indicator light wouldn't light up.  The MacBook showed it was running from battery.  I unplugged it immediately but was in the middle of something important continued working since I showed I had 95%-ish battery remaining.  At around 45% I had completed my tasks and went to plug it in using the 'desk' charger.  The charge light wouldn't light up and the on-screen indicator showed that it was running only from battery.  The desk charger still works on an older MacBook Pro I have, so I can see that the charger works fine.

After some diagnosis I believed the MagSafe board had gone bad.  I bought one from Amazon and installed it.

It worked!  At this point my Mac's battery was at 1%, so I left it closed in sleep mode and charged it until the charge indicator on the power supply went green.  I left it closed and didn't touch it.  About 30 minutes later, I heard it restart on it's own.  At this point, the light on the cable wasn't on anymore.  It was still plugged in.  I opened it and let it boot with the charger still attached.  It showed it was running from battery only and wasn't charging.  I used it long enough to run a backup and I'm down around 40% before shutting it down.

All signs seem to point to a bad MagSafe board again.  The desk charger still works with other MacBooks.  I've ordered a second replacement MagSafe board that will be here in a few days.  I'm concerned that the problem will present itself again.  What else should I be looking into?  Battery?  Logic board?  Gremlins?

Thanks for your replies!  I'll do my best to post updates and answer any questions.

기기:

MacBook Pro 15" Unibody Mid 2012

현황:

-open
+closed

원문 게시자: Bryan W ,

제목:

Multiple MagSafe Board Failures

텍스트:

Hi all.

I have a MacBook Pro 15" Unibody mid-2012.  I have two 85w power supplies that I use interchangeably.  One stays at my desk at home and the other travels with me.

While using the 'travel' charger the other day, I heard a pop (I think from the charger/brick) and the charging indicator light wouldn't light up.  The MacBook showed it was running from battery.  I unplugged it immediately but was in the middle of something important continued working since I showed I had 95%-ish battery remaining.  At around 45% I had completed my tasks and went to plug it in using the 'desk' charger.  The charge light wouldn't light up and the on-screen indicator showed that it was running only from battery.  The desk charger still works on an older MacBook Pro I have, so I can see that the charger works fine.

After some diagnosis I believed the MagSafe board had gone bad.  I bought one from Amazon and installed it.

It worked!  At this point my Mac's battery was at 1%, so I left it closed in sleep mode and charged it until the charge indicator on the power supply went green.  I left it closed and didn't touch it.  About 30 minutes later, I heard it restart on it's own.  At this point, the light on the cable wasn't on anymore.  It was still plugged in.  I opened it and let it boot with the charger still attached.  It showed it was running from battery only and wasn't charging.  I used it long enough to run a backup and I'm down around 40% before shutting it down.

All signs seem to point to a bad MagSafe board again.  The desk charger still works with other MacBooks.  I've ordered a second replacement MagSafe board that will be here in a few days.  I'm concerned that the problem will present itself again.  What else should I be looking into?  Battery?  Logic board?  Gremlins?

Thanks for your replies!  I'll do my best to post updates and answer any questions.

기기:

MacBook Pro 15" Unibody Mid 2012

현황:

open