주요 콘텐츠로 건너뛰기

기기를 수리하세요

수리할 권리

상점

도움말

현재 버전 게시자: iRobot ,

제목:

Won't charge battery, sometimes powers off when battery installed

텍스트:

Hello!  I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed.  When a battery is installed, the computer often dies suddenly in the middle of the boot process, although with some batteries it doesn't do this.  I've tried several known-good ACs and batteries, so I know those aren't the issue.  Removing and installing batteries when the computer is on also seems to make it cut off occasionally.  The computer is not charging batteries either.  I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X.  The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't.  It also won't run off of battery power with the AC disconnected.  Again, the laptop works 100% fine when a battery isn't installed.

Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installed while on) I'm wondering if it might be something else, maybe a short or a connection issue?  This machine was working fine for weeks, and the customer just returned it with this issue.

I took a look inside, and there's nothing obvious.  The internal battery connector is secure and looks fine.  Any ideas?  I just have a hunch that it's not the DC-in, although maybe I'm just in denial that I need to spend $50 and replace it.  :-)

Also, and not to overly complicate this, but one of the two little "posts" inside the battery compartment that the battery is supposed to lock into is broken off, however I don't think this is the issue, as the battery is still secure, and the behavior still persists when I make sure to hold the battery firmly in place, etc.

Thanks!

기기:

MacBook Pro 15" Core Duo Model A1150
MacBook Pro 15" Core Duo Model A1150

현황:

open

승인된 답변:

25884

편집자: rdklinc ,

제목:

Won't charge battery, sometimes powers off when battery installed

텍스트:

Hello!  I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed.  When a battery is installed, the computer often dies suddenly in the middle of the boot process, although with some batteries it doesn't do this.  I've tried several known-good ACs and batteries, so I know those aren't the issue.  Removing and installing batteries when the computer is on also seems to make it cut off occasionally.  The computer is not charging batteries either.  I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X.  The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't.  It also won't run off of battery power with the AC disconnected.  Again, the laptop works 100% fine when a battery isn't installed.

Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installed while on) I'm wondering if it might be something else, maybe a short or a connection issue?  This machine was working fine for weeks, and the customer just returned it with this issue.

I took a look inside, and there's nothing obvious.  The internal battery connector is secure and looks fine.  Any ideas?  I just have a hunch that it's not the DC-in, although maybe I'm just in denial that I need to spend $50 and replace it.  :-)

Also, and not to overly complicate this, but one of the two little "posts" inside the battery compartment that the battery is supposed to lock into is broken off, however I don't think this is the issue, as the battery is still secure, and the behavior still persists when I make sure to hold the battery firmly in place, etc.

Thanks!

기기:

MacBook Pro 15" Model A1150

현황:

open

승인된 답변:

25884

편집자: rdklinc ,

제목:

Won't charge battery, sometimes powers off when battery installed

텍스트:

Hello! I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed. When a battery is installed, the computer often dies suddenly in the middle of the boot process, although with some batteries it doesn't do this. I've tried several known-good ACs and batteries, so I know those aren't the issue. Removing and installing batteries when the computer is on also seems to make it cut off occasionally. The computer is not charging batteries either. I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X. The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't. It also won't run off of battery power with the AC disconnected. Again, the laptop works 100% fine when a battery isn't installed.
 
Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installed while on) I'm wondering if it might be something else, maybe a short or a connection issue? This machine was working fine for weeks, and the customer just returned it with this issue.
 
I took a look inside, and there's nothing obvious. The internal battery connector is secure and looks fine. Any ideas? I just have a hunch that it's not the DC-in, although maybe I'm just in denial that I need to spend $50 and replace it. :-)
 
Also, and not to overly complicate this, but one of the two little "posts" inside the battery compartment that the battery is supposed to lock into is broken off, however I don't think this is the issue, as the battery is still secure, and the behavior still persists when I make sure to hold the battery firmly in place, etc.
 
Thanks!

기기:

MacBook Pro 15" Model A1150

현황:

open

편집자: rdklinc ,

제목:

Won't charge battery, sometimes powers off when battery installed

텍스트:

Hello! I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed. When a battery is installed, the computer often dies suddenly in the middle of the boot process, although with some batteries it doesn't do this. I've tried several known-good ACs and batteries, so I know those aren't the issue. Removing and installing batteries when the computer is on also seems to make it cut off occasionally. The computer is not charging batteries either. I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X. The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't. It also won't run off of battery power with the AC disconnected. Again, the laptop works 100% fine when a battery isn't installed.
 
Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installedinstalled while on) I'm wondering if it might be something else, maybe a short or a connection issue? This machine was working fine for weeks, and the customer just returned it with this issue.
Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installedinstalled while on) I'm wondering if it might be something else, maybe a short or a connection issue? This machine was working fine for weeks, and the customer just returned it with this issue.
 
I took a look inside, and there's nothing obvious. The internal battery connector is secure and looks fine. Any ideas? I just have a hunch that it's not the DC-in, although maybe I'm just in denial that I need to spend $50 and replace it. :-)
 
Thanks!

기기:

MacBook Pro 15" Model A1150

현황:

open

편집자: rdklinc ,

제목:

Won't charge battery, sometimes powers off when battery installed

텍스트:

Hello! I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed. When a battery is installed, the computer often dies suddenly in the middle of the boot processprocess, although with some batteries it doesn't do this. I've tried several known-good ACs and batteries, so I know those aren't the issue. Removing and installing batteries when the computer is on also seems to make it cut off occasionally. The computer is not charging batteries either. I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X. The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't. It also won't run off of battery power with the AC disconnected. Again, the laptop works 100% fine when a battery isn't installed.
Hello! I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed. When a battery is installed, the computer often dies suddenly in the middle of the boot processprocess, although with some batteries it doesn't do this. I've tried several known-good ACs and batteries, so I know those aren't the issue. Removing and installing batteries when the computer is on also seems to make it cut off occasionally. The computer is not charging batteries either. I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X. The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't. It also won't run off of battery power with the AC disconnected. Again, the laptop works 100% fine when a battery isn't installed.
 
Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installed) I'm wondering if it might be something else, maybe a short or a connection issue? This machine was working fine for weeks, and the customer just returned it with this issue.
 
I took a look inside, and there's nothing obvious. The internal battery connector is secure and looks fine. Any ideas? I just have a hunch that it's not the DC-in, although maybe I'm just in denial that I need to spend $50 and replace it. :-)
 
Thanks!

기기:

MacBook Pro 15" Model A1150

현황:

open

원문 게시자: rdklinc ,

제목:

Won't charge battery, sometimes powers off when battery installed

텍스트:

Hello!  I've got a 15" 2GHZ Core Duo aluminum Pro that works 100% perfectly on AC power if there is not a a battery installed.  When a battery is installed, the computer often dies suddenly in the middle of the boot process.  I've tried several known-good ACs and batteries, so I know those aren't the issue.  Removing and installing batteries when the computer is on also seems to make it cut off occasionally.  The computer is not charging batteries either.  I'll get the lightning bolt indicating it's charging, but it will eventually turn to an X.  The light on the DC-in shows amber, so it's as if it thinks it's charging, although it isn't.  It also won't run off of battery power with the AC disconnected.  Again, the laptop works 100% fine when a battery isn't installed.

Normally I'd say it's the DC-in/sound board, but due to suspicious factors (power cutting when a battery is installed) I'm wondering if it might be something else, maybe a short or a connection issue?  This machine was working fine for weeks, and the customer just returned it with this issue.

I took a look inside, and there's nothing obvious.  The internal battery connector is secure and looks fine.  Any ideas?  I just have a hunch that it's not the DC-in, although maybe I'm just in denial that I need to spend $50 and replace it.  :-)

Thanks!

기기:

MacBook Pro 15" Model A1150

현황:

open