도움말

현재 버전 게시자: Marco Magnano ,

제목:

Thick black vertical stripe on iMac screen after HDD to SSD swap

본문:

Hi all, I read this discussion

[post|225705]

and I apparently have a very similar problem.

[image|905166]

The thing that's different in my case is that:

– The display is in perfect conditions: I've been very cautious in cutting the adhesive strip.

– I discharged static electricity following the iFixit guide and I used antistatic gloves to protect the board.

– I accidentally pulled, or stretched, the flex data cable. The connector on the logic board is ok, but the cable could be damaged.

When I move a window I can see something in the black stripe, and the screenshots are OK.

[image|905165]

and every external screen or Cintiq tablet works perfectly.

So, I'd like to replace the cable with a new one, but I can't find it, I always find only the flex cable for A1311, but I don't think that it's the right one.

Somebody knows where to find the right cable, or if the A1311's one could be OK?

Alternatively, is it possible to repair the flex cable, maybe soldering again the contacts?

Thanks!

Marco

기기:

iMac Intel 21.5" EMC 2544

현황:

open

승인된 답변:

341886

편집 작업: Marco Magnano ,

제목:

Thick black vertical stripe on iMac screen after HDD to SSD swap

본문:

Hi all, I read this discussion
 
[post|225705]
 
and I apparently have a very similar problem.
 
[image|905166]
 
The thing that's different in my case is that:
 
– The display is in perfect conditions: I've been very cautious in cutting the adhesive strip.
 
– I discharged static electricity following the iFixit guide and I used antistatic gloves to protect the board.
 
– I accidentally pulled, or stretched, the flex data cable. The connector on the logic board is ok, but the cable could be damaged.
 
When I move a window I can see something in the black stripe, and the screenshots are OK.
 
[image|905165]
 
and every external screen or Cintiq tablet works perfectly.
 
So, I'd like to replace the cable with a new one, but I can't find it, I always find only the flex cable for A1311, but I don't think that it's the right one.
 
Somebody knows where to find the right cable, or if the A1311's one could be OK?
 
Alternatively, is it possible to repair the flex cable, maybe soldering again the contacts?
 
Thanks!
 
Marco

기기:

iMac Intel 21.5" EMC 2544

현황:

open

원문 게시자: Marco Magnano ,

제목:

Thick black vertical stripe on iMac screen after HDD to SSD swap

본문:

Hi all, I read this discussion

[post|225705]

and I apparently have a very similar problem.

The thing that's different in my case is that:

– The display is in perfect conditions: I've been very cautious in cutting the adhesive strip.

– I discharged static electricity following the iFixit guide and I used antistatic gloves to protect the board.

– I accidentally pulled, or stretched, the flex data cable. The connector on the logic board is ok, but the cable could be damaged.

When I move a window I can see something in the black stripe, and the screenshots are OK.

[image|905165]

and every external screen or Cintiq tablet works perfectly.

So, I'd like to replace the cable with a new one, but I can't find it, I always find only the flex cable for A1311, but I don't think that it's the right one.

Somebody knows where to find the right cable, or if the A1311's one could be OK?

Alternatively, is it possible to repair the flex cable, maybe soldering again the contacts?

Thanks!

Marco

기기:

iMac Intel 21.5" EMC 2544

현황:

open