주요 콘텐츠로 건너뛰기

기기를 수리하세요

수리할 권리

상점

도움말

현재 버전 게시자: pifia ,

텍스트:

I am having a similar problem with my 13” 2009 MacBook (white, unibody). Just last week it seemed like the charger top was having problems connecting, got it to work for a few minutes, and then suddenly it stopped working at all; (nothing on screen, no fans).Now the computer does not turn on at all and I don't get any lights on either of the two 60 chargers’ tips, both which work just fine in my 2012 13” MacBook Prounibody, A1342).
I am having a similar problem with my 13” 2009 MacBook (white, unibody). Just last week it seemed like the charger top was having problems connecting, got it to work for a few minutes, and then suddenly it stopped working at all; (nothing on screen, no fans).Now the computer does not turn on at all and I don't get any lights on either of the two 60 chargers’ tips, both which work just fine in my 2012 13” MacBook Prounibody, A1342).
 
IJust last week it seemed like the charger top was having problems connecting, got it to work for a few minutes, and then suddenly it stopped working at all; (nothing on screen, no fans, no lights of any color on charger tip of computer).[br]
[br]
So far I
have tried:[br]
-SMC reset, NVRAM reset[br]
-move MagSafe charger port back out to just-behind case[br]
-disconnect battery and SSD[br]
-confirmed this model is to use 60W charger[br]
-change charger to a newer one, with pins
not yet triedpushed as far in[br]
[br]
So changing the charger PLUS doing the SMC reset specifically as victorclausson suggested gets the computer
to bitboot, so long as the battery is disconnected. During the process of figuring this out, the screen displayed some very strange patterns on boot, the inside side of the MagSafe port area was sparking one time, and every time I get it to start up without connected battery, orthen the system reset wherefan runs at a very high speed.[br]
[br]
I am able to run Hardware Test, with no errors detected. In Terminial
I reconnecthave run ‘pmset -g batt’ and it tells me the computer is drawing from AC Power, and the Battery is disconnected. If I boot up with the battery disconnected, then plug the battery in, it still gives me the same report. STRANGELY enough, if I then remove the charger while holding the power button,computer is running, the computer is still able to run for a few minutes.[br]
[br]
This computer has an OEM battery that was purchase with the computer in 2009. It has has incredible life and until this week, had more cycles left on it than the battery I bought for my MBP from MacSales two years ago. So if it has failed, it must have done
so overnight and quite drastically.

Then again, my wife is not that gentle with her computer and can often be found abusing the cord by letting it bend. And this model is notorious for cracking plastic around the ports, so the charger can physically fit onto the MagSafe port in a few different ways that are not appropriate.[br]
[br]
What shall
I will try those soon and report back.next? I can boot up to Internet Recovery now with claussens reset method, but every few minutes or so I have to do the SMC reset.

[br]
Is it possible that the charger with poor pin connection would have caused some destruction to the computer innards, namely the MagSafe board, the battery, or the main board?
IJust last week it seemed like the charger top was having problems connecting, got it to work for a few minutes, and then suddenly it stopped working at all; (nothing on screen, no fans, no lights of any color on charger tip of computer).[br]
[br]
So far I
have tried:[br]
-SMC reset, NVRAM reset[br]
-move MagSafe charger port back out to just-behind case[br]
-disconnect battery and SSD[br]
-confirmed this model is to use 60W charger[br]
-change charger to a newer one, with pins
not yet triedpushed as far in[br]
[br]
So changing the charger PLUS doing the SMC reset specifically as victorclausson suggested gets the computer
to bitboot, so long as the battery is disconnected. During the process of figuring this out, the screen displayed some very strange patterns on boot, the inside side of the MagSafe port area was sparking one time, and every time I get it to start up without connected battery, orthen the system reset wherefan runs at a very high speed.[br]
[br]
I am able to run Hardware Test, with no errors detected. In Terminial
I reconnecthave run ‘pmset -g batt’ and it tells me the computer is drawing from AC Power, and the Battery is disconnected. If I boot up with the battery disconnected, then plug the battery in, it still gives me the same report. STRANGELY enough, if I then remove the charger while holding the power button,computer is running, the computer is still able to run for a few minutes.[br]
[br]
This computer has an OEM battery that was purchase with the computer in 2009. It has has incredible life and until this week, had more cycles left on it than the battery I bought for my MBP from MacSales two years ago. So if it has failed, it must have done
so overnight and quite drastically.

Then again, my wife is not that gentle with her computer and can often be found abusing the cord by letting it bend. And this model is notorious for cracking plastic around the ports, so the charger can physically fit onto the MagSafe port in a few different ways that are not appropriate.[br]
[br]
What shall
I will try those soon and report back.next? I can boot up to Internet Recovery now with claussens reset method, but every few minutes or so I have to do the SMC reset.

[br]
Is it possible that the charger with poor pin connection would have caused some destruction to the computer innards, namely the MagSafe board, the battery, or the main board?

현황:

open

원문 게시자: pifia ,

텍스트:

I am having a similar problem with my 13” 2009 MacBook (white, unibody). Just last week it seemed like the charger top was having problems connecting, got it to work for a few minutes, and then suddenly it stopped working at all;  (nothing on screen, no fans).Now the computer does not turn on at all and I don't get any lights on either of the two 60 chargers’ tips, both which work just fine in my 2012 13” MacBook Pro.

I have not yet tried to bit up without connected battery, or the system reset where I reconnect the charger while holding the power button, so I will try those soon and report back.

현황:

open