Skip to main content
도움말

현재 버전 게시자: oldturkey03 (투표 내용) ,

제목:

Lost IMEI, Modem FIRMWARE, Bluetooth, Wifi and Service

본문:

Hello!

I just replaced the screen of my iPhone 4, it has been laying a long time without battery since i tried to replace it 20 days ago and then managed to rip the screen cable. Just got the new cable and mounted everything.

I admit i have no control whatsoever if all screws are on correct positions and i see that that is impotent. But first i want to know if something is broken? The iPhone works perfectly, i have even managed to jailbreak it with IOS5. I've lost all radio on it, bluetooth, gps, gsm, wifi and in the settings i cant see IMEI, ICCID, Modem Firmware Wifi or Bluetooth address. WiFi says "N/A" and Bluetooth address says 00:00:00:00. WiFi is greyed out too.

I've tried to move the screws around, even checked the connectivity of the small cable next to the battery connector. Should be ok! The top "cover" is missing the metal piece which should connect the screw to the logic board. But that is only "wifi" antenna and should result in bad-wifi-reception as i have figured out? So that might not be the cause?

Other than that i have tried with every plate connected, so why i lost "all" radio connection i cant seem to figure out. This is giving me an headache, i have an sister which wold love to get this phone working since i just bought the new 4S.

Worth mention that on the top cover plate I'm missing a screw the yellow on this : http://guide-images.ifixit.net/igi/ZUVK6lNKwxLpBNLj.medium

Any good advices?

Edit: The yellow screw on that image, there is no entry for a screw below it as i can see? should there be? And does it have anything to say for gsm, bt, gps not showing?

기기:

iPhone 4

현황:

open

승인된 답변:

138092

편집 작업: thorleif ,

제목:

Lost IMEI, Modem FIRMWARE, Bluetooth, Wifi and Service

본문:

Hello!
 
I just replaced the screen of my iPhone 4, it has been laying a long time without battery since i tried to replace it 20 days ago and then managed to rip the screen cable. Just got the new cable and mounted everything.
 
I admit i have no control whatsoever if all screws are on correct positions and i see that that is impotent. But first i want to know if something is broken? The iPhone works perfectly, i have even managed to jailbreak it with IOS5. I've lost all radio on it, bluetooth, gps, gsm, wifi and in the settings i cant see IMEI, ICCID, Modem Firmware Wifi or Bluetooth address. WiFi says "N/A" and Bluetooth address says 00:00:00:00. WiFi is greyed out too.
 
I've tried to move the screws around, even checked the connectivity of the small cable next to the battery connector. Should be ok! The top "cover" is missing the metal piece which should connect the screw to the logic board. But that is only "wifi" antenna and should result in bad-wifi-reception as i have figured out? So that might not be the cause?
 
Other than that i have tried with every plate connected, so why i lost "all" radio connection i cant seem to figure out. This is giving me an headache, i have an sister which wold love to get this phone working since i just bought the new 4S.
 
Worth mention that on the top cover plate I'm missing a screw the yellow on this : http://guide-images.ifixit.net/igi/ZUVK6lNKwxLpBNLj.medium
 
Any good advices?
 
Edit: The yellow screw on that image, there is no entry for a screw below it as i can see? should there be? And does it have anything to say for gsm, bt, gps not showing?

기기:

iPhone 4

현황:

open

원문 게시자: thorleif ,

제목:

Lost IMEI, Modem FIRMWARE, Bluetooth, Wifi and Service

본문:

Hello!

I just replaced the screen of my iPhone 4, it has been laying a long time without battery since i tried to replace it 20 days ago and then managed to rip the screen cable. Just got the new cable and mounted everything.

I admit i have no control whatsoever if all screws are on correct positions and i see that that is impotent. But first i want to know if something is broken? The iPhone works perfectly, i have even managed to jailbreak it with IOS5. I've lost all radio on it, bluetooth, gps, gsm, wifi and in the settings i cant see IMEI, ICCID, Modem Firmware Wifi or Bluetooth address. WiFi says "N/A" and Bluetooth address says 00:00:00:00. WiFi is greyed out too.

I've tried to move the screws around, even checked the connectivity of the small cable next to the battery connector. Should be ok! The top "cover" is missing the metal piece which should connect the screw to the logic board. But that is only "wifi" antenna and should result in bad-wifi-reception as i have figured out? So that might not be the cause?

Other than that i have tried with every plate connected, so why i lost "all" radio connection i cant seem to figure out. This is giving me an headache, i have an sister which wold love to get this phone working since i just bought the new 4S.

Worth mention that on the top cover plate I'm missing a screw the yellow on this : http://guide-images.ifixit.net/igi/ZUVK6lNKwxLpBNLj.medium

Any good advices?

기기:

iPhone 4

현황:

open