주요 콘텐츠로 건너뛰기

Larger version of the Nintendo DSi, released March 2010 in North America. Most repairs are accomplished with only a screwdriver and prying tools.

136 질문 전체 보기
질문 마감됨

DSi XL not charging, both fuses working

My little brother spilled water on his DSi XL some time ago (a month or two) and the system stopped working. I recently replaced the fried battery and it turns on and works fine, but it still won't charge (the orange light turns on for a second, then turns off). I've tried different outlets as well as another AC adapter, with the same result.

After reading similar questions here, I tried checking the F1 and F2 fuses as most people suggest, but they are both fine. The power socket also seems fine, as there is a connection from the inside to the motherboard. Is there another part of the board that could be causing this due to corrosion damage?

I also noticed that the on-screen battery indicator on the top screen shows that it's charging despite the orange light saying otherwise. Does this mean anything?

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요

답변 1개

가장 유용한 답변

Tyler the first thing I would suggest is to properly clean your logic board as well as all connectors. Since the DSi XL had water damage, you are just in time to experience corrosion failure. Clean your logic board and all connectors and cable ends with isopropyl alcohol and a soft brush. Check all SMD components for corrosion. You also did not tell us how you checked the fuses....After you properly clean the boards, reassemble and re-evaluate.

해당 답변은 도움이 되었습니까?

점수 1

댓글:

Thanks for the reply. Sorry for leaving that detail out; I used a multimeter to test the resistance of the fuses, and they both gave a reading of zero resistance. I'll readily admit that I don't have much experience with electronics and circuitry so please let me know if I should use a different method. I've cleaned the boards as you instructed. Some components on the main board seem to have suffered from corrosion, I cleaned them as best I could. Here's a picture showing which ones they are http://i.imgur.com/EiebT.jpg After reassembling, the DSi still won't charge the battery

Sounds like you did the right thing and the fuses have continuity. The corroded parts are awfully close to the power board and it is entirely possible that they are at least partially responsible for it not charging. Do you see any markings on the components?

The pins/ends of the component look blackened or faded a bit

You think you could post a close up?

Unfortunately, the camera I have can't focus too well up close (no macro setting) so the best shot I can get isn't very good. http://i.imgur.com/fo3dm.jpg If something on the board needs to be replaced, then I'm afraid that'll be as far as I go, as I haven't the means to do so

의견 추가하세요
조회 통계:

24 시간 전: 0

7일 전: 1

30일 전: 1

전체 시간: 2,434