Model A1311 / Mid 2011 / 2.5 & 2.7 GHz Core i5 or 2.8 GHz Core i7 Processor

324 질문 전체 보기

HDD Fan speed 0, CPU fan speed at maximum

I tried to add a SSD, to my iMac 21.5 2011.

I followed the steps from the guides (iMac Intel 21.5" (Mid 2011) Dual Hard Drive Kit). I din't have a SATA power cable, so I used a power spitter. I took the power from the HDD and split it to the SSD.

The iMac found the SSD and its HDD, but the fans went crazy.

The optical drive fan works as it should (I left the thermal sensor). The HDD drive fan indicates 0rpm, and the CPU fan goes at full throttle.

I removed the SSD and left only the HDD. But the fans remained the same.

I also tried http://www.hddfancontrol.com/ but it's not doing anything for the fans.

Any tips or info, that would help me solve this, is appreciated.

iMac Intel 21.5" (Mid 2011) Dual Hard Drive Kit 이미지

상품

iMac Intel 21.5" (Mid 2011) Dual Hard Drive Kit

$27.99

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

2개의 답변

선택된 해법

Try an SMC reset - your kluge may have caused problems with the EFI. Fans run at high speed by default if temp sensors report out of range or failed (your HDD fan sensor could be the cause of the fan problem). If the reset doesn't work you'll have to figure out if a fan is indeed shot.

A fan control app should work - but with one fan out you could cook you CPU so I wouldn't use one anyway.

If this answer is acceptable please remember to return and mark it.

해당 답변은 도움이 되었습니까?

점수 1
의견 추가하세요

I found the problem. I haven't connected the HDD fan to it's power socket. (>_>).

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Ispas Adrian 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 2

지난 30일: 6

전체 시간: 759