Model A1136 / 30, 60, or 80 GB hard drive / black or white plastic front

853 질문 전체 보기

cant restore because the iPod is busy

I replaced the click wheel, front face, and battery in my 30 gig video iPod. When I connect it to the computer it suggests restoring it. I hit restore it starts the process then after awhile it stops to say it can't restore because the iPod is in use. The Apple site suggests many things such as turning enable and disable disk on or off but i dont have that option in the summary of the iPod in itunes. I only have the restore button. What should i do? Is it a hard drive issue?

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요
Fixmas/픽스마스 분위기를 띄우세요
FIXMAS12 코드로 $50 이상 구매시 $12 할인을 받으십시오
Fixmas/픽스마스 분위기를 띄우세요
FIXMAS12 코드로 $50 이상 구매시 $12 할인을 받으십시오

3개의 답변

선택된 해법

Posted by bac on Feb 2nd:

Why can't restore my iPod?

"no guarantee, but here's something you could try.

1) try forcing your iPod into Disk Mode first

- simultaneously press and hold the Menu and Center buttons

- the iPod should reboot after a few seconds. Immediately upon seeing the Apple logo:

- simultaneously press and hold the Center and Play/Pause (bottom) buttons

- the iPod should now say "Disk Mode" on top with a check mark and "OK to disconnect" in the middle of the screen

connect your iPod via USB to your Mac (you don't say but I'm assuming you have a Mac??)

then run Disk Utility, select the iPod hard drive in Disk Utility and try to Erase the iPod hard drive. Select Format: Mac OS Extended (if on a PC, just format the iPod as FAT32)

after erasing the iPod, unplug it, reboot it (press and hold Menu and Center buttons)

then plug it in and connect to iTunes, and see if you can restore it now.

2) by the way, did you know there's a hidden diagnostic mode in most iPods? you won't be able to fix your restore-failure problem, but if there some hardware problem in your iPod the diagnostic mode might point out something

to enter diagnostic mode with the 5th gen iPod:

- reset the iPod by holding down Menu and Center button

- immediately upon seeing the Apple logo, press and hold the Center and Previous (left) buttons

- you should hear a beep and see "SVC Diag Boot" on top of the screen

- from there you can press Menu to enter manual tests

- once in the Manual tests, use the scroll wheel and center button to navigate

- under the "IO" subsection you can find various HardDrive tests, including checking SMART status, HD model & serial #, etc. supposedly there is also a Disc Scan test, but for some reason on my 5th gen iPod I don't see that option"

해당 답변은 도움이 되었습니까?

점수 2
의견 추가하세요

I did some of this and was unsuccessful (Disk Utility would not let me reformat the iPod disk). I also updated to the latest version of iTunes (no luck there, either). What ultimately worked was I forced the iPod into disk mode and then tried to run restore from iTunes. It took a few minutes but the restoration worked. I'm currently syncing and am hoping this fixes the problem.

해당 답변은 도움이 되었습니까?

점수 2

댓글:

This is the only thing that worked for me. 80GB iPod Classic to iMac OS 10.9.5 and iTunes 12 and USB.

I did try and erase the iPod via Disk Utility first, but that seemed hung after 5 hours. Just Forced Quit and tried the above mentioned Disk Mode then connect USB and then open iTunes. Restore.

의 답변

Signed in just to say that this worked for me. I have a 160GB iPod Classic, OS X 10.12.6, and iTunes 12.6.2.20. My iPod had been having difficulty syncing to my iMac for a week or so and had tried just about everything. What worked in the end was exactly this. It took about 5-10 minutes for the Restore process to get started but after that, everything started working again.

의 답변

의견 추가하세요

My 20GB iPod could not be erased in disk utility (Unable to write to the last block of the device) and iTunes rejected it due to it being busy. Maye it's a hard drive problem on the iPod?

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

haven693 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 7

지난 7일: 24

지난 30일: 98

전체 시간: 10,919