Why are my fans doing so little to lower heat?

I recently did an install of a new I/O board on my MacBook Pro due to a bad Magsafe connector. After starting up my computer, I noticed it was running a few degrees hotter then it previously had. About an hour later, while idling, the fans kicked into high gear and iStat Pro showed them as running at max speed (6200 RPM). I figured it was because it was warm and dismissed it. After the CPU temperature came back down to around 50 C, however, the fans did not spin down like they should, I waited about 30 minutes before turning off my laptop just to be safe.

Now today I was watching a Flash video (which I realize is very CPU intensive) and my CPU temp went up to 75 C, and still climbing while the fans ran full power. I've had this laptop for 3 years and never had an issue with heat. Is it possible that a temperature sensor was damaged during the install of the I/O board? Did I go anywhere near the sensors? I'm not even sure where they are, to be honest. I wish I could run the AHT, but I've lost the DVD that came with my computer (I blame the frequent moves on this). Is there any other way to figure out what the problem could be? I guess if this rambling is a bit unclear, I'm wondering why the fans are spinning so high when nothing is happening, and at the same time doing very little to actually cool the computer.

Thanks.

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

2개의 답변

선택된 해법

Just a follow up on my comment. If your fans are blowing hard but the machine is not doing anything I would check and reseat the cables to both fans since you write that you have replaced some parts. If the temp sensors are not connected properly the fans do not know when to kick in and out.

해당 답변은 도움이 되었습니까?

점수 2

댓글:

agreed +

의 답변

의견 추가하세요

Hmm...To me, it sounds like you did not re-seat the CPU and GPU correctly. There are small bumps and imperfections between the chips and the heat sync. If those gaps aren't filled by something (normally a sort of special wax for laptops) this sometimes happens. Go to Newegg.com and order some Arctic Silver 5, then go to their website for details on how to apply it correctly.

Hope this helps!

해당 답변은 도움이 되었습니까?

점수 0

댓글:

Now he never mentioned he had disassembled the CPU but of course after some years the paste between the CPU/GPU and the cooler could be inefficient. Replacing it after several years always helps. But I would also check that and cables are seated good after opening and replacing parts inside. Could also be one fan is disconnected and the other would have to work like crazy to cool it.

의 답변

Read the question -

의 답변

의견 추가하세요

귀하의 답변을 추가하십시오

TrevorS 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 0

지난 30일: 1

전체 시간: 1,615