Skip to main content

2010년 중반기 모델 A1278 / 2.4 or 2.66 GHz Core 2 Duo 프로세서

833 질문 전체 보기

Why is the power not getting from the charger to the board?

I bought a Macbook Pro 2010 "As-is, for parts" because I wanted to mess around with one and see if I could figure out how to repair it.

When I received it I found that the issue was worse than the "boots to folder with apple logo" as the MBP would not charge. In order to fix this I ordered a charger the it and a Magsafe DC-in board.

After replace the Magsafe DC-in board and plugging in the new charger, the light does not light up on the Magsafe charger and the battery indicator does not show that it is charging.

I booted to Ubuntu through a flash drive and it shows the charging symbol in Ubuntu when the charger is connected and goes away when it is unplugged so I assumed it would be fine.

After working on troubleshooting some other issues, bad RAM, I could no longer turn on the MBP. The battery indicator showed 2 lights and I can't boot with the charger.

I plugged in the battery to another MBP and it was charging, the charger works on the other MBP, and I have tried to reset SMC.

Currently the MBP battery is dead and no lights show up on the battery indicator and the charger still doesn't show any lights.

Inspected the logic board doesn't reveal any noticeable damage, physical or liquid, and I'm just wondering where I could go from here to try to fix the issue.

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 2

댓글:

When booting to a OS X USB installer it also reported that it was printing.

There seems to be more damage so I will be getting rid of the machine without figuring out what caused issue.

If you are experiencing this same issue I wish you luck.

의 답변

의견 추가하세요

맥북 배터리 수리 키트

기본 가격은 $69.99

Buy Now

맥북 배터리 수리 키트

기본 가격은 $69.99

Buy Now

2개의 답변

가장 유용한 답변

Check U6900 & U6901, see that SMC_BC_ACOK is making its way to U6901 and that it is shooting this to U6900.

Check current sense resistors R7020, R7021, R7022, and the traces from them to U7000.

Check CHGR_ACIN pin of U7000 if SMC_BC_ACOK is not being shot out of U7000. If it has 4v on it and you are not getting SMC_BC_ACOK, replace U7000.

해당 답변은 도움이 되었습니까?

점수 1
의견 추가하세요

If you are able to get green light on adapter you can try smc reset left shift control option and power at same time might fix it make sure the MagSafe on the mobo is fully seated and make sure seated properly to side of case to get full contact with adapter also unplug battery try seeing if can power on with just adapter if nothing works might be motherboard issue or faulty battery indicator on side of machine. Check underside of motherboard for liquid damage or anything noticeably wrong if nothing find new board online or ask Apple store to do exchange with apple for new board

해당 답변은 도움이 되었습니까?

점수 0

댓글:

So I can get an orange light if I plug it into another mac then switch it over, but the SMC reset doesn't do anything and it won't turn on (currently without battery). With the battery I had charged in another MPB I was able to boot into Ubuntu.

The charger doesn't show a light but Ubuntu says it is charge. There are some display issues occuring in Ubuntu though (Details is Deta*ls, where * is some non language character).

Does that verify that it is the logic board?

의 답변

의견 추가하세요

귀하의 답변을 추가하십시오

huffjoshua 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 0

지난 30일: 1

전체 시간: 508