5S Won't charge after power bar failure

Hi everyone. So I've fixed hundreds of customer phones but I'm actually struggling with my personal phone now.

My 5S was charging fine through a power bar with a USB port built into it. I checked my phone later and noticed it was no longer charging.

I look at the power bar and there's smoke starting to come out of the power bar.... I immediately unplugged the phone but the damage was done.

What happens now is i get the "this device may not be supported" error and it refuses to charge. It will take a charge if I turn the phone off and leave it plugged in, however my battery life is about 40% what it would previously do, and seems to run hotter than usual.

I've tried different plugs, cords & outlets. no charge

I've tried a new battery, no charge

my last effort was a new charge port flex, no charge.

Does this mean something on the motherboard has been fried? where do I go from here?

Thanks for any suggestions.

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요