주요 콘텐츠로 건너뛰기

Black and silver single cup coffee maker with water reservoir on the left hand side. K40/K45.

98 질문 전체 보기

Add water, Heating, and Medium cup buttons flash but no coffee!

I recently moved cities and after unpacking I noticed my Keurig is no longer working. When I turn my Keurig on, the machine will display the add water, heating and medium cup buttons and they will all be blinking. I tried to replace the external water reservoir and even opened up the bottom of the Keurig to drain the internal reservoir however I have not seen any results. If anyone has had a similar problem, please feel free on what to do in order to fix this.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 17
댓글 4개

This may or may not help...

There is an internal check-valve that shuts the pump off if it senses back-pressure. Some people have success just squeezing the internal check-valve to break up calcium clogging it.

(I thoroughly cleaned my own out like this guy did, but you may not want to go that far.)


Good luck!

I removed the reservoir, took a butter knife wrapped in a piece of paper towel, and pressed/jiggled the bottom thingy (that the reservoir sits in and senses water). Bingo! Coffee again.

I did the process countless times. Turned machine off then back on, then pressed a button (I rotated). It finally worked and I’m sipping my coffee now. It sounds like the machine is struggling to prime

Jason Bieber’s answer worked for me!

댓글 달기

답변 15개

가장 유용한 답변

I just came across this problem myself. Nothing suggested worked. So I pressed and heldto middle cup button while all the lights were flashing until they stopped, all the cup lights came on solid, I opened and closed the k cup basket. Then pressed the middle size cup button again, and it dumped a lot of hot water, about 12 to 14 Oz. More than the largest cup size, and now it is running normal again. Hope this helps.

해당 답변은 도움이 되었습니까?

점수 73

댓글 69개:

I got my new Keurig for Christmas and it worked great until my wife used it, nor sure qhay she did wrong but that did the trick for me too Jason, Thanks!

I tried all the other fixes to no avail. Then I saw Jason's fix and it worked. Voila!

Yes!! This totally worked after trying all the other ideas. Thanks.

You sir, are the hero that we needed this evening! I almost drove to the store for a new coffee pot. Thanks!

How long did you hold it? Because it doesn't seem to be working for me :(

댓글 64개 더보기

댓글 달기

I see this is an old post but just in case anybody else runs across it I had the same problem. When you remove the top cover of the water reservoir the Overflow elbow at the top of the reservoir should be clear silicone looking plug your finger over the top of it open the Keurig K-Cup holder close it back hit the Brew button with your finger still held over the elbow and it should Purge the air from the line and get you back to working

해당 답변은 도움이 되었습니까?

점수 18

댓글 25개:

I tried Josh's idea but it started blinking again. So, I pulled the entire water reservoir off the Keurig, held over the sink and push in on the water value (on the bottom of the reservoir) and let some water out. Turned off Keurig, reattached the water reservoir and turned it back on. Opened and shut the K-cup lid. and made a cup of coffee.

None of these are working for me. Same lights come on - middle cup, ad water, and the red heating light come on. Any other great ideas? The Keurig hotline was no help. Thank you

Thanks so much for taking the time to answer this question! It saved me a lot of trouble and frustration this morning! :)

I tried all those with no luck. However, I pushed the "Auto Off" and the "Power" buttons at the same for several seconds and that did the trick. The water in the reservoir started to heat properly and now I am descaling my Keurig to sale in our garage sale.

This worked for me too with a little tweaking. Initially simply covering the silicone elbow's hole didn't do anything. I had to do it several times mixing in squeezing, lightly pulling, and pumping the elbow several times before it worked. Each time, I had to open the pod holder and close it to "reset" it. Soon a little water came out, then a little more. Then, the lights went back to normal and soon I was back in business. The model K40 manual, though nicely laid out, wasn't helpful

댓글 20개 더보기

댓글 달기

While it’s doing all that blinking and humming:

  1. Take off the reservoir lid.
  2. Grab hold of the reservoir with one hand and pump the tank up and down (basically lift the tank up a little and bring it back down, over and over).
  3. At the same time, with your other hand, cover the overflow elbow plastic tube at the top of the reservoir. You’ll feel a slight suction the more you pump.
  4. Hopefully one or both of the cup buttons are lit-press one when it’s trying to pump the water through, cover the elbow again here and there to create suction. Water should flow through where the coffee goes.

Side notes:

This is the model with just two size cup options, power and auto off buttons, and lights for add water, descale, and heating.


When turned on, it would hum for a while before any other light would come on. When it did, add water, heating, and one cup light were blinking. Water would not pass through.


Cleaned out the needle part with a paperclip.

Opened the top part and squeezed the tubes in case there was blockage.

Pressing auto off and power button at the same time.

All the tips and videos I could find, etc, but maybe they all helped contribute to fixing it but it wasn’t until I pumped the reservoir AND covered the elbow that it worked.


해당 답변은 도움이 되었습니까?

점수 5

댓글 9개:

Had the exact same problem this morning --- This suggestion fixed my problem - Just purchased the keurig 2 months ago

Mine as well. Thanks!

Some water comes out with this trick, but the problem still persists. And I have to put my fingers on the plastic tube all the time. :(

This totally worked! Must've either been clogged with grounds or an air pocket. :) Hurrah and thanks.

You, Sir ... are a Keurig BOSS!

Got mine up and running again. Thank you!

댓글 4개 더보기

댓글 달기

I also had this issue and tried all of the above solutions to no avail :( I called the help line and what they told me worked!

  1. Unplug your Keurig.
  2. Straighten out a bobby pin.
  3. Open the lid and locate the needle that enters into your k-pod. Be careful, this is extremely sharp!
  4. Use your bobby pin and insert it into the 2-3 holes (depending on your model) in the needle. Do this for each hole 10-12 times.
  5. Plug in your Keurig and brew a few water only cups until the water is clear and free of coffee grinds.
  6. Enjoy your coffee and clean Keurig.

해당 답변은 도움이 되었습니까?

점수 3

댓글 2개:

Kim1885's tip worked for me. Used a straightened paper clip and made it into an "L", inserted 1 3/4 in -2in deep into each of the holes 15 times. Be very careful of the needle. Good luck!

Kim1885’s tip worked for me! Thanks!

댓글 달기

Had same code. The top needle that punctures the K-Cup was clogged. Turn off..Remove water tank... Open K-Cup basket... Tilt machine back enough to see pin.... Carefully insert a needle or pin to clear the obstruction. I then ran a few large cups through with No cup in basket to flush out the grounds. Repeat if necessary.

해당 답변은 도움이 되었습니까?

점수 2
댓글 달기

My issue was the mesh at the bottom of the water tank was clogged with a layer of film. I found the issue by taking the water tank off, then while holding over the sink pressed up on the valve on the bottom of the tank. No water came out. I then rinsed the water tank out several times with very hot water and the film came off and water started flowing. Probably using vinegar would have worked better, but its back working now.

해당 답변은 도움이 되었습니까?

점수 1

댓글 1개:

Thank you! This was the only thing that worked for me. I also used vinegar as suggested. It works perfectly now.

댓글 달기

I have tried all these fixes and none work. I get to the point of brewing and nothing comes out. I followed the directions all the way to pushing the middle size cup button, and nothing happens. Can anybody help me?

해당 답변은 도움이 되었습니까?

점수 0

댓글 3개:

Did all the following “

I tried all those with no luck. However, I pushed the "Auto Off" and the "Power" buttons at the same for several seconds and that did the trick. The water in the reservoir started to heat properly and now I am descaling my Keurig to sale in our garage sale.” and no luck

I had been hitting large cup to brew and decided to try med cup brew and that seem to do the trick. Thank you all for your help

After trying all these great suggestions, I too tried the med cup, and it worked.. I did whack it a couple times when it acted like it was gonna brew.. now on to the OTR micro and then the wife… thanks everyone

FINALLY, after trying the suggestions in this thread, pressing the medium cup button worked! It must have brewed from water airlocked in the system because the water level in the reservoir never went down during the process. It also brewed a large cup worth of coffee. Thanks Dan Davis and Gary McKinnon.

댓글 달기

What you are describing is a brewing system blocked error. In other words the system is unable to move liquid through the brewing system. Unplug the maker.

1) Dirt or grounds may be lodged into the water injector. This is often an issue if you grind your own coffee (making the grind too fine). You will need to get a fine sewing needle (or pin) to attempt to clear out the needle that the maker uses to insert into the K-Cup.

2) Water tank connection to the maker being blocked by debris. The blockage can be in the water tank itself or in the connection on the brewer. I used a toothbrush and some vinegar to clean both areas.

Once I did that I plugged it in and it started working. I then descaled the maker and haven’t had issue since.

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:

Pressing the middle button didn't work at first but reading through the comments I tried each suggestion then came to the one that "whacked" theirs.. I tried it heard two really low hums ( I thought I really messed up) pressed the middle button again the blinking stopped and then I ran a cycle as usual and it works... If saner heads prevailed I think priming the pump would have worked too. Nonetheless thanks to your comments I have my Keurig back! Thank you!

I tried most all of the suggestions one at a time and finally have my coffee, one hour after trying to have my first cup this morning. I have some sort of problem every time I clean it!! Thanks for all the suggestions everyone.

댓글 달기

Jest keep turning on and pushing cup button it's bold up it takes a while to

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Mine was flashing all 3 lights water, heat, and middle blue, when you turned it on it like "clicked" or a pump sound. I raised and lowered side reservoir and bubbles came out I did it until bubbles stopped was only lifting 1/2 inch I also did it withy finger over silicone thing at the top back until water came out . Also used a needle in nozzle that dispenses coffee. Turned it back on and it worked for 1 cup each size . Now I'm going to descale etc .

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

This was the best and answered my problem with mine bc mine didn't make coffee either but does now you will find

it at www.fluentincoffee.com (if this is wrong contact and I will get the correct site) KEURIG TROUBLESHOOTING. How to fix 10 common problems with Keurigs (if this is wrong contact and I will get the correct site)

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Same problem here. What worked for me was selecting the small cup which worked than medium and full cup.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Tried all did not work for me. The add water, heating light and middle coffee size button were flashing and it made a noise like it was trying to pump water. I tried the pumping method while holding the overflow tube. I knew there had to be air in the system. I found a plastic tube not quite half inch inside diameter, I squeezed the overflow into the end of the tube and sucked the other end while the maker was making the noise trying to pump. After about 3 seconds I got the air out and it has worked since. Hope that blesses someone.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Hello all.

just wanted to post here one of the fixes I found that worked on two different machines.

I found that if the machine sits for a while, the valve in the arm portion starts to stick closed and cannot pump water out.

Here’s a tutorial with pictures on how to get to it and how to open it up.

1) (Model specific) You have to take the two screws off that hold the opener lever onto the machine. 2 star bit screws.

Block Image

2) Next open the pod arm and take the two screws out that hold the top portion on.

Block Image

Block Image

3) Close arm and gently wiggle the top portion of the arm until it comes off. Do not force it!!! There are two retaining feet that hold the top portion on. (Pictured are the feet and the holes on the sids of the tube that the feet go in.)

Block Image

Block Image

4) Next is to remove the two screws, holding the silicone tube down.

Block Image

5) Remove the silicone tube and gently create a vacuum on silicone tube. I used my mouth to pull a vacuum on the tube (be very careful if your machine has already heated up the tank). This should break the rubber one-way valve loose, and water should flow again. (Image is where the rubber one-way valve is.)

Block Image


Put machine back together in order it was taken apart and then run a cycle.

Hope this helps.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Ripped a domino sugar piece off bag and used it for a filter and used a knifecut k cup puted k cup into newly made domino sugar filter and made coffee in ground coffee maker which was okay but that was only becaae On my model of kureg k cup coffee single cup machine cleaned it last night with hot water then cleaned hole pan thing then put small pin hole thing cover back on and put tank water and k kuo plugged it on and tried to run it no lights nothing then was on phone and it came on on its own spewing water/ coffee on its own lights were dim for k cup sizes and machine was making a loud humming sound I unplugged it plugged it back it still same humming and water and coffee till water in tank was empty then still humming so I unplugged it for over night rinsed coffee grinds and tank and machine. Cleaned up mess of water and coffee spill. In the morning this morning put water in tank on back of machine and filled it halfway with water I put cover on it put coffee cup under spout wear coffee cones out turned on machine waited for water to heat up and then lifted kcup lid thing shut it the k cup machine lights for cups lit up blinking blue small medium large coffee cup sizes so I tried small cup of water and it worked so I shut it off after. Now it works :) anyone else try this? I MADE Myself a mcdonalds cappichino hot then spilled it 9j rug in living room while typing this up. Great stat to today. As it wasin living room floor rug. But got spill cleaned up. Anyone else Having trouble

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

Ryan Bialaszewski 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 24

7일 전: 221

30일 전: 1,239

전체 시간: 144,209