13” 화면 MacBook Pro 모델

6576 질문 전체 보기

Battery not working after upgrading Hard Drive

Hi all!

I received a late 2011 13" MacBook Pro with a 2.8 Ghz i7. The computer was 100% working and the only problem was that the screen had some wobble to it.

So it disassembled it, removed the screen, tightened the loose hinge screws and put the screen back in. I also went ahead and pulled the stock 750 Hard Drive and installed a Sata III SSD.

I booted it and everything looked great until I noticed that the battery wasn't charging. In System Profiler the battery shows normal condition with 90 cycles. If I remove the MagSafe, the computer turns off. Without the MagSafe plugged in, the battery button on the side of the Mac doesn't light up anything.

So I reset the SMC and the PRAM. That did nothing. I redid my install process for the hardware that I touched. I left the battery unplugged for an hour. I'm still stuck. When I unplug the MagSafe, the battery lights on the side flash for a second. I know that the battery worked normally before I messed with it. The same charger works normally with my other MacBook.

Any ideas?

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

US$100 이상 또는 Pro Tech Toolkit을 포함한 모든 주문의 배송은 무료입니다!

상점 둘러보기

1개의 답변

선택된 해법

I'll answer my question. Apparently the battery was bad. It only showed 100 cycles, and the status was normal, but it showed that it wasn't charging and would die if I unplugged the power adapter. After rebuilding the computer several times, I went out on a limb and purchased a cheap battery off of Amazon. That battery worked immediately and is charging normally. I don't know if I somehow damaged the original battery when I first opened the computer, but the problem was definitely a bad battery.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Josh 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 0

지난 30일: 0

전체 시간: 37