주요 콘텐츠로 건너뛰기

2009년 6월 출시 / 2.66, 2.8, 또는 3.06 GHz Core 2 Duo 프로세서

301 질문 전체 보기

Can't install OSX el capitan, stuck on installation screen


Was trying to instal el capitan on my macbook , the installation starts and after a few minutes stops and a messaging saying the os x could'nt be install on the computer, please contact the software editor to get help.

I called apple and they said they can't give me any tech support, i guess cause my computer is too "old"..

I tried a few times, can't go back with my old os and i'm stuck on the installation program.

I made sure before trying that my computer had all it needs to install it.

Is there a way to complete the installation or go back to my old os without loosing all my data? I did a back up but a month ago..

Thank you for your help!!

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 18
댓글 4개

hi ,iv tried updating to el capitan and i seem to be stuck on the install screen ,every time i turn the computer off i can't seem to get many options,how do i get out of it to change the date so it will hopefully install,thanks

Setting back the date to 2015 did not work for me. Another error message popped up, and said that my installation file was "probably corrupted" (freshly donwloaded from the Apple Store).

The only solution that worked was complicated and klutzy: 1. find a computer with installed MacOS 10.11. 2. Clone the other Mac's HD on a USB disk with CarbonCopyCloner, making sure the clone is bootable (include a working copy of CCC in the process). 3. Clone the USB disk with CCC to the Mac you're trying to upgrade. 4. erase the original user's data and put in your own info.

I was lucky — my son had a MacBook 2008 just like the one I was trying to upgrade, and he graciously lent me a working backup disk to do this with.

Apple's response to the problem was highly unsatisfactory. I called their support number (I live in Italy), a representative answered from Greece. I explained the problem, they gave me a telephone appointment for the next day, and never called back. Baaaad, guys.

I hаd a similar іѕѕuе, Mу OS installation was giving me errors..

Fіnаllу I mаnаgеd to resolve thе problem.

Follow thіѕ guide hеrе: https://bit.ly/2SuNVrJ

Hope thіѕ helps

@Lindsay thank you for the link. It was helpful. Please kindly also provide a solution for High Sierra.

댓글 달기

답변 10개

선택된 해법

El Capitan disk has an embbed security certificate that has expired in 2016.

Just change your system date, let's say to 01/01/2015, install El Capitan, then change the date back to today.

해당 답변은 도움이 되었습니까?

점수 20

댓글 23개:

Where did you hear this?

Check also the comments on this video, using 2016 doesn't work, using 2015 works:


OK, now I understand what you were going here.

If you allow the system to loose the date & time it will revert to the default setting that's in its ROM. At that point you won't be able to install the OS as the installer is expecting the certificate it has and the systems date to be equal or newer than its date (not expired, just predated the window it is valid for). The certificate has a window it is valid for (a start and end date) if the systems date is outside of this window you can encounter problems.

So yes, you do need to make sure the systems date and time are correctly set before trying to do the OS install.

Just adjust the date in a terminal session: date

date mmddhhmmyyyy

댓글 18개 더보기

댓글 달기

When that message appears, go under disk utilities, click "terminal," and once that pops up, type "date" and hit enter. The date will probably appear as incorrect (mine was set at the year 2000). Type date again and then type in the correct date in the format MMDDHHYYYY (month, day, hour, year) and hit enter. Then try installing again. It worked for me!

해당 답변은 도움이 되었습니까?

점수 5

댓글 18개:

Yes, your systems date & time needs to be set correctly. This is also true with the older OS's too. The installer won't install based on a setting that is older than its self.

this didnt help me. rip.

@Samari Curbelo - This is not the correct answer! But, its close! Apple messed up the certificates on the newer macOS releases Sierra to Mojave. If you are trying to install something older you do need to mess with the data setting! But its not putting it to today 2020 You need to back date to the time point the OS was released. So that could be back in 2011 for Lion!

where do you find terminal in disk utilities?

Dan is right. I reset the date to 1 day before the release of El Capitan (09/29/2015) and everything installed perfectly

댓글 13개 더보기

댓글 달기

This happened again with an Apple Store upgrade of El Capitan here in 2019, which is really incompetent behavior on Apple's part.

I fixed it by setting the system clock in terminal to 12-31-2015 using terminal once it was stuck in its upgrade loop, which allowed it to continue despite its expired certificate in the upgrade image. It resync'd the clock back to the normal time during the upgrade process.

해당 답변은 도움이 되었습니까?

점수 3

댓글 3개:

Yes, Apple messed up the certificates on the newer macOS's. Here's the full story you've got an old macOS install image, it will probably stop working today Apple often lets the certificates expire to prod people to newer versions and/or newer hardware. Here the patched OS's:

How to upgrade to macOS Sierra

How to upgrade to macOS High Sierra

How to upgrade to macOS Mojave

Jump to Step 4 for the link to the installer file.

Anything older you need to back date the system for the OS installer to work.

How did you get to the system clock to reset it?

Courtney click on the date and time in your task bar.> open date & time preferences > unlock it > turn off the automatic Apple time > roll the date back to a couple for months after the installer date. Now do your install, then reset your date and time.

댓글 달기

What did you do the backup to and how was it done? How was the El Capitan obtained? Have you been getting beach balls before this started?

My first thought on this is that it is probably a bad hard drive/IR cable and I would replace it with a new one from a 2012 model.

해당 답변은 도움이 되었습니까?

점수 2

댓글 1개:

I did my back up on an external drive. Wasn't getting any beach ball before and I got the el capitan on the apple website. My computer worked completly well before trying the installation.. I doubt it's a hard drive/IR problem

댓글 달기

If you have a friend with a Mac you could try connecting it to yours via a FireWire cable and put your system in Target Mode. That way you can salvage your important files just to be on the safe side here onto an external HD.

해당 답변은 도움이 되었습니까?

점수 2
댓글 달기

I’m (of course) the one poor sod out here that none of this date reseting is working for…

Picked up a mid 2009 MacBook Pro 17”. It has the latest firmware on it. It came with El Capitan installed and I hadn’t realised it was a slightly older model that I couldn’t upgrade.

I’ve tried everything imaginable to get this %#*@ thing back to El Capitan but nothing works.. I get this same infuriating message every time. I ‘m going to bin the bloody thing in a minute!

I’ve tried dates between 2015 and 2018 nothing… same same same…

I’ve run the installer from a bootable USB drive. set the time and date numerous times in terminal.. nothing works.

해당 답변은 도움이 되었습니까?

점수 0

댓글 8개:


I had the same problem going round in circles until I disconnected WiFi and Ethernet as the computer kept resetting the date to the present day after I had changed it to 2017. It worked for me then!

Hope this helps, good luck

@paul ray - Yep you need to break the connections to the internet so the back dating doesn't get overriddened by the internet time servers!

Using the Bootable OS installer is the only way to get to El Capitan.

Same thing happened to me. Finally I just started putting in dates and when I did it one day later it worked!!

Would it make a difference to if you got the 10.11 install on a machine that has its clock rolled back to 2015?

My machine is stuck on “About a second remaining” for about 20mins now

댓글 3개 더보기

댓글 달기

As of mid 2020, it seems the date has to be set in 2016 (I used a summer 2016 date), not 2015 (later than 2016 may also work, from other comments). See some further details and steps clearly outlined at this link: https://superuser.com/questions/1495770/...

해당 답변은 도움이 되었습니까?

점수 0

댓글 2개:

I have put various dates from 2015 to 2017 and still without success on my mid 2009 macbook... SUPER FRUSTRATED

@Konrad Skylark - You don't need to go to such extremes. Just get the updated OS installers I posted above.

댓글 달기


I just wanted to say that all you people who are in this discussion are friggin’ AWESOME! For every little problem that I ran into trying to upgrade my laptop from Snow Leopard to El Capitan, you had a solution, and they ALL WORKED!

Thank you to all of you,


해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

The year has only last two digits not yyyy but YY

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

I have the same problem trying to reinstal elcapitan to my old apple desk top but it won't allow me to change the date from the terminal???

its going in the bin!!!!

해당 답변은 도움이 되었습니까?

점수 0

댓글 1개:

I downloaded EL Capitan from Apple today 09-04-2024

I keep getting errors, so I set the time and date to today..... or in 2015, 2016... still getting errors... o seconds remaining.... error try again.... driving me nuts, I made a new post regarding this Installing El Capitan on a stubborn 2008 MacBook in 2024 and I am still struggling.... help.

댓글 달기

귀하의 답변을 추가하세요

Eline 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 7

7일 전: 50

30일 전: 153

전체 시간: 87,137