메인 콘텐츠로 스킵하기

모델 A1418 / Late 2012 / 2.7 & 2.9 GHz Core i5 또는 3.1 GHz Core i7 프로세서

159 질문 전체 보기

iMac Black Screen; LED 1&2 lit, Fan spinning

Hi,

I got an iMac 21.5 Late 2012 which is not turning on. Diagnosis LED 1&2 are on when I press the power button, fan is spinning, HDD too, but nothing else happens. I have already exchanged the CPU, still no luck, RAM is checked and working.

I now suspect the NVIDIA graphics chip to be broken as the 3rd LED is signaling the connection to the GPU.

Any comments/experience if this could be right? Any other suggestion to fix this?

My thanks,

Marcus

Update (14.02.2018)

Hi,

so to close off this repair, I found out that the WiFi module was defective, I just replaced it and everything works fine again. So if you see the same failure on your iMac, just remove the WiFi module and see if the iMac is working again.

Cheers

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

3개의 답변

가장 유용한 답변

With the system back together see if either of these diagnostic tricks helps in identifying your problem:

  • Plug in an external display in does it show your desktop?
  • Shine a flashlight into the screen at a sharp angle can you see a faint image of your desktop icons?

If either of these work your backlight is having problems not the LCD or GPU.

If the external display works but you can't see anything with the flashlight trick you have a cabling issue between the LCD and the GPU or the power cable is bad.

해당 답변은 도움이 되었습니까?

점수 2

댓글:

Thanks Dan,

unfortunately there is no image if I connect an external display. I would wonder if that would work as the diagnostic LED 3 does not light up and no chime will be played when I turn on the iMac, so the system is not starting/booting.

I guess that it is safe to say it is not a display issue.

의 답변

의견 추가하세요

Hey guys, how did you end up on this? I have exactly the same issues with my iMac (same model). Sometimes there is no Image, but I can hear the chime, another time I get a picture, but without chime. Then I get to see the progress bar while booting up. It gets filled up to approx. 50% and the screen goes black.

The strange thing is, that once in a while the Mac boots up completely and works fine until I restarted or I switched it off.

By the way, Apple hardware test says the system is not facing any issues?!

I also assumed the GPU may be faulty, but by booting the iMac into recovery mode I get a video signal and I am also able to connect my external monitor via thunderbolt/ miniDP to extend the screen. I have no idea what to do :/

해당 답변은 도움이 되었습니까?

점수 0

댓글:

What does your screen look like when shining the flashlight into it as well as what does the image look like with an external monitor plugged in?

의 답변

Well, it does not seem to be a backlight fault as I do not see any icons while pointing a flashlight towards it. Also the 3rd. board LED does not light up. I assume it would get lit up independent of the backlight status, right?

Concerning the image of pluging in an external Monitor via TB/MiniDP...

There is no signal while booting up the regular way/showing the status bar - only if I enter the recovery menu I can drag the windows to my external monitor without any faults/distortions etc..

Am I right in assuming that showing the recovery screen means the GPU is working fine or is this menu generated by some other component, e.g. the CPU integrated graphics?

의 답변

Ouch not good! ;-{

Your system has in fact two graphics engines. The dedicated GPU (NVIDIA GeForce) and the one within the CPU chip (Intel HD Graphics). Startup settings that don't require the dedicated GPU driver will run the Intel HD Graphics services. So in your case the NVIDIA GeForce GPU has a failure.

의 답변

Hm, so you are pretty sure this is the issue? I am wondering why sometimes a boot up is possible. I also thought about a faulty PSU, which may not be able to supply the full power as soon as the GPU gets started up. Somewhere I read, that there is a possibility to deactivate the NVIDIA GPU, using the intel HD Graphics instead. Not sure if this could be a solution...

Btw.: Why isn't there any note concerning a faulty graphics card while using AHT?

의 답변

As the condition is sporadic AHT may have not seen the fault. I'm sure a bad power supply would have effected both. It can't hurt to try a new power supply if you have one. Also keep in mind AHT only goes so far.

As to disabling the dedicated GPU, while that could be done I don't see that as being effective or useful in either usage or diagnostically.

의 답변

7에 댓글 더 나타내기

의견 추가하세요

Just to keep you guys updated. Meanwhile I replaced the PSU, which didn't have any effect on the described issue. So the PSU is not the culprit here. As a proper startup happens in approx. 1 of 100 startups, it is not that easy to et access to those crash log files. Does anyone know another way? Maybe I can use the hdd to boot my macbook from?

One more thing:

If I dismantle the Imac and get closer to the upper part of the logicboard there is a sizzling noise somewhere around the CPU area (marked in the following image)

Block Image

I am not 100% sure, but I think it could arise from the component the arrow is pointing towards (What is this anyway?).

So while trying to proceed further in identifying the issue, I am looking for a replacement board as well. Does anyone know if all A1418 boards will fit into a late 2012 iMacs case and also do have the same connectors (display, fan, PSU, speakers etc.)? How about a late 2015 non 5k board in particular?

Cheers

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

MacMarcus 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 0

지난 30일: 1

전체 시간: 403