주요 콘텐츠로 건너뛰기

기기를 수리하세요

수리할 권리


Laptop will not charge, does not recognize power cable

So I bought an Asus ROG G751JT 8 months ago, and it's been fine up until last month, when it stopped charging plugged into the power cord (The green battery charging light does not come on). Didn't use it for a few days thinking it was bricked and would have to be sent in for repairs, but then one day it magically decided to charge again.

Everything's been good and fine up until last night, when while I was using it (stationary, on a table) the brightness of my screen changed a few times, indicating the laptop switching back and forth from AC to battery power, and it is now back to not charging at all. Is the laptops power adaptor connection to blame? The cable fits snugly, but perhaps not as snugly as I would like (there is a little give to it when wiggled side to side).

Really sort of bummed out that my first $1,500 foray back into Windows as resulted in a bricked computer in under a year, when my Mac has been chugging along for over 6. Any help would be really appreciated. :(

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 2


Had this issue since day one. My GL702VT is not usable unless it's plugged into the mains. Total waste of space

I have the same laptop and am having literally the exact same issue, I had it 8 months in and sent it back to get it fixed when it was under warranty, but after that another 8 months went by, the warranty went up and now it's doing it again. Does any one else know if this is a common issue and if so can we get some people together and go to Asus about it?

It's happening to me as well. 2nd time it's happened over the span of a couple months. Asus quoted me $1300 to fix the &&^&^$^ thing. If you're having trouble still, email me so we can get something done about this. Marcuscabeceira@gmail.com

I have a G751J, I was having the same problem only my laptop would shut off randomly. I took it apart and found that the fans were not running, from research I have done the battery can go bad in these laptops due to overheating and since the batteries are not meant to be replaced in this laptop you would need to take it somewhere to get it fixed. But I am still in the process of getting mine fixed so once I have more info on what went wrong I will come back and share

I've been the merry owner of a G751 JY for 3 years. It's been a few weeks though since I have started experiencing a similar problem. Computer past warranty.

Pc would stop charging when playing a game, for most games, even $@$*!& ones.

Often it would start charging again after shutting down the game, but sometimes I was just f***ed and I would have to try and find solutions online as my battery was going empty pretty fast (hey its a rog)

Got it to a repair store so that they could tell me if battery/adapter/connector was at fault. Ended up bummed 90dollars for a new ac block that in the end did not fix it. Pc worked normally for a few days after being back from the store though.

Knowing asus's kinda prices for repair, i disassembled it, tried to make it work without battery, same problem except it would shut down instead of stopping the charge.

I proceeded to fully unscrew/unplug everything and put it all back up, and it worked, until I transported it to another place.

1에 댓글 더 나타내기

의견 추가하세요

필수 도구 키트

최고의 소형 키트에서 가장 유용한 도구.

지금 쇼핑하기

필수 도구 키트

최고의 소형 키트에서 가장 유용한 도구.

지금 쇼핑하기

답변 6개

가장 유용한 답변

The same thing that happened to me exactly the way you described it except for the fact that the plug didn't work it didn't at first but I found a way to make it work and that was when I powered it up the (laptop) I hold down the delete button and play with the shift button up and down after 8 or 9 tries then the computer will see the plug but it won't show the battery charging only for a brief moment then that stops and the computer State on I hope that helps

해당 답변은 도움이 되었습니까?

점수 1
의견 추가하세요

Definitely, try first with some other Power charger. If this is not the case then you have a problem with Power chip on your motherboard. You will have to find nearest Reair shop which is able to do a little bit of Micro soldering.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Just confirm if it's the brick first.

Got a Multi-meter? Prong the end and check if there's any power going through.

Use setting

And VΩ jack + COM jack on the meter itself.

해당 답변은 도움이 되었습니까?

점수 0


My only other laptop is a 6 year old Mac that still runs like a champ, with its magnetic power connection.

I do not have a Multi-meter, just a fairly broke college student here. =/

But like I said, the green light on the power adaptor box turns on when plugged in, but it fits into the computer itself somewhat loosely. You can easily bend it perhaps 1mm or so in any direction when it's plugged in. I was thinking perhaps this was by design to absorb shocks/bangs, but maybe it's just a terrible port that breaks easily.

Well if that were true, you'd be able to wiggle the plug and achieve a connection.. even when loose. Mine is loose, it connects fine.

Oh by the way, you're talkin' to your little sister. ;d (G750JX)

Have you tried cleaning out the port with a toothbrush or something?

Multi Meters are $5-10 and worth it, just grab a cheap one.. all you need to do is be able to read if there's a connection.

My thoughts is your plug has broken internally which is a common issue. Also, if you're in College, do you have an Electronics Department? ;d

의견 추가하세요

I had this problem the last couple of weeks on my Asus g750jh

When playing games it started to constantly switch between battery and ac power, if I had the battery out of the unit it would just straight up crash, eventually it would stop charging the battery and the unit would not power on again randomly for hours later. I tried different power supplies, checked all the hardware inside the laptop, changed bios settings, you name it.

After extensively trying to find solutions (including the problem disappearing for a week and then suddenly returning) I eventually established the problem is with the latest nVidia GTX drivers.

Using cpu-z I was able to analyse the power states of the graphic card, it normally goes into "idle" power mode when not gaming. Upon inspection the card kept glitching into "pwr" mode when going from "idle" to unrestricted mode, this "pwr" mode restricts the graphic card when running from the battery. Whenever this would happen it would cut power to the ac adapter and begin a constant loop until the laptop would refuse to turn on again..

The last time this happened I immediately installed these drivers from 2015 after reading a post on another forum suggesting its a driver issue with GTX 600+ cards, and have not had a single problem since.

Driver version no : 347.25


Version 347.25 - WHQL

Release Date Thu Jan 22, 2015

Operating System Windows 7 64-bit

Windows 8.1 64-bit

Windows 8 64-bit

Windows Vista 64-bit

Language English (US)

File Size N/A

My laptop is running better then it has been all year going back to these drivers. For anybody having these problems on an ROG with a GTX, try this solution.

해당 답변은 도움이 되었습니까?

점수 0


Well thanks for your feedback mate I've been having the exact same issues as you describe, with it looking "fixed" for a week and then going all nuts again. All I hope is it will charge again so I can try your fix.

Martin, I am experiencing this same problem. Has your laptop let itself charge again? I am in the same boat as you. Not recognizing the charger and now dead. For others reading, when the laptop still had battery power and was plugged in, it did not say "Plugged in, not charging" it did not recognize being plugged in at all.

I was playing a game on a high graphics setting at the time I had noticed the the laptop was not charging. It was plugged in. Laptop did not recognize it was plugged in.

Notes: Tested power cable, seeing 19.5 V. Green light is on. I have never heard any beeping from it.

Windows 10

GTX 970M - Driver Version unknown right now since dead.

How did u fix it ? Same problem here

Well, I wouldn't be so sure about definitely "fixing it", but buying a new AC adapter for nothing kind of got on my nerves, so I :

-fully disassembled / dusted / cleaned / put new thermal paste / checked all connectors. I then unplugged the battery and reassembled, turned computer on, it worked, I made sure not to launch any game

-Then I uninstalled all graphics pilots I had installed. I also uninstalled all battery and AC connector pilots. I downloaded the graphics pilot in the aforementionned comment. First time I tried to install it, computer shut down(lets remind here that battery was unplugged, second time it worked

-I backed up then cleant all errors in registry with ccleaner (tho idk if it is necessary nor wise to do)

-I then restarted the computer, then turned it off, plugged battery back in, powered it and tadaaa it worked. At least for now. I let it at my parents' and try to transport it the least possible, bought a new one (desktop) at my place.

의견 추가하세요

Same issue, I have the G751JT.

Randomly wont charge even though its plugged in.... Tried new drivers, and BIOS.

Took the battery out, wouldnt turn on.

Assuming its the Brick, bought a new one off Amazon said it was for the g751. Came today, was too small of a pin...... called asus and had to buy a special one for the G751JY/JT for $150......

Hopefully that fixes it.. well see

UPDATE: yes it was my cord. appears to work now

해당 답변은 도움이 되었습니까?

점수 0


I have this problem, bur i have checked if ther comes any power to the place wher the batteri is. And i get power ther so i dont know what to do. Any tips?

의견 추가하세요

I had this problem after changer one of the drives. The battery isn’t charging, as if it’s just not connected. So the battery is simply useless right now. PC works perfectly fine, I just need to plug it in to use it, which is somewhat of a bummer.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Tim Gentry 가/이 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 3

7일 전: 24

30일 전: 135

전체 시간: 13,251