Mac mini A1176 boots once, then not again, after EFI boot changes

Short Form

After installing Ubuntu on my 2006 Mac mini, and following the procedure to get it to EFI boot straight to the GRUB bootloader, my Mac mini will no longer reliably boot up. If I open the machine up and disconnect all connectors and boards, and then reconnect them, it will boot up fine the first time and operate completely normally, but the next time I restart, it comes back up with no startup chime, black screen, and no power to my USB keyboard or mouse. It doesn't respond to any startup key sequences (cmd-opt-p-r, 'c', etc). Any ideas what might be causing this?

Long Form

I'll start by saying that I don't have high hopes of getting this fixed after all the shenanigans I've been pulling on this machine recently. But you all love a challenge, don't you? So, here we go.

First, some history. I have a 2006 Intel Mac Mini (MacMini1,1). It was originally a 1.83 GHz Core Duo, and I upgraded it to a 2.16 GHz Core 2 Duo processor in January 2013 (following the iFixit guide, of course). At that time I also flashed its firmware to the MacMini2,1 firmware, the thinking being I'd want to increase the RAM to 3GB at some point (which I haven't done). I used the guide here:,... -- but for whatever reason I never did the steps to upgrade to Lion.

It's been working smoothly since then, but in the past month or so I started getting the urge to install Ubuntu Linux on it, since Apple has long since stopped supporting this model and Mac OS X 10.6.8 was getting long in the tooth. I used this guide: and was able to successfully manually boot the Mac into Ubuntu. I was also able to get it to boot using rEFInd. I should probably have left well enough alone, but I felt the need to get it to boot directly into the GRUB boot loader. So I followed the more detailed steps here: , and that's where my boot-up trouble started, as described in the short form opening paragraph.

I have since been able to pull the drive out of the Mini and put it in a USB enclosure. When I hook the enclosure up to a MacBook, I'm able to examine all the files on the disk and everything seems normal. I took the steps to remove the Ubuntu partitions from the disk, and also removed the ubuntu files from the EFI system partition, just in case those were causing problems. At that point I was able to boot the MacBook into Mac OS X 10.6.8 from this drive, and everything appears as it did previously on the Mini. I put the drive back in the Mac mini and attempted to boot, and the first time I booted, it booted up fine. The system operated normally. Oddly, the system actually booted itself up as soon as I plugged in the power cord. However, after I tried to reboot (I selected the 10.6.8 disk in the startup disk control panel and rebooted), on each ensuing reboot I get the following symptoms:

1. Power led turns on, and you can hear the optical drive checking itself.

2. Startup chime does not sound.

3. Monitor remains black - screen status flickers between analog/digital.

4. USB mouse light flickers on briefly, then power.

5. Mini does not respond to any keyboard commands on startup (tried C to boot from a CD, cmd-opt-P-R to reset PRAM, cmd-S and cmd-V for single-user and verbose modes).

I'm puzzled as to why it will boot up the first time after disassembly/reassembly, but not after restarts/shutdowns. It almost seems like the disassembly causes some setting to be cleared, allowing it to initially boot, but when it restarts, some new or remembered setting takes over and doesn't allow it to boot again.

I have also tried booting from the Firmware Restoration CD 1.7, thinking that perhaps the firmware has been corrupted, but the Mini just keeps the CD in the drive and doesn't to any booting or firmware restoration. I'm guessing it's because I had upgraded the firmware to MacMini2,1, and the firmware restoration CD only has MacMini1,1.

So...... any ideas?

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글 1개:

Are you able to boot up using an external bootable OS-X drive?

댓글 달기