메인 콘텐츠로 스킵하기

1.86GHz 또는 2.13GHz 프로세서, 128GB 또는 256GB 플래시 저장공간

160 질문 전체 보기

Internal Speakers not present only Headphones

Hello Team,

I have a very frustrating issue.

A customer has come to my shop with a this Macbook air for the internal sound not working.

First of all I noticed that the "Alt Sound Option" was only showing Headphones, when none were plugged in.

So I replaced the IO board and data flex connecting it to the main board, no change to issue.

Then I used a USB drive with a known good copy of OSX on it, no change to issue

Next I replaced the logic board, no change to issue.

Next I removed the logic board from the chassis incase there was some kind of short from the casing, I set the logic board and IO board up in my test bay and connected only the required hardware to boot the device.

So the state of play so far is, new logic board, new IO board and flex, no SSD, OSX loaded from external HDD, no wifi board, new internal speakers connected, new fan.

THE ISSUE IS STILL PRESENT.

How can this be possible?

I should note that the start up chime works .

Also when using headphones the sound is really low on both IO boards and logic boards, but when I would use the MIDI setup and mute either channel one or two on the output the sound is at the correct volume on the headphones.

Also note internal speakers do not appear anywhere in the MIDI setup only headphones, even with new parts.

Any Help would let me sleep tonight.

Cheers

Brendan

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1

댓글:

Nope, wasn't able to fix it

의 답변

Could you fixed this?

I have the same problem

의 답변

I'm having this exact same issue. Have tried four different I/O boards. They can't all be bad. One of them was certified as "new" and looked totally new. Mint condition, with NO indication a magsafe had EVER been plugged into it (e.g., no marks or dirt, etc). So even with a brand-new I/O board...exact same issue.

의 답변

의견 추가하세요

1개의 답변

선택된 해법

Sounds like liquid damage on the audio circuit on the logic board, generally near the audio chip. Typically if you do buy boards from like eBay they tend to have issues because if they were working fine they would actually be used to be assembled as a laptop and sold as a laptop to make more money.

해당 답변은 도움이 되었습니까?

점수 2

댓글:

Nope wasn't that, in total i used 3 different logic boards and IO boards and the issue was still present, also just to let you know, we source our parts from an official apple part supplier in the UK

의 답변

Was the system ever reinstalled?

의 답변

We used three different known good versions of OS X on three different USB drives

의 답변

의견 추가하세요

귀하의 답변을 추가하십시오

Brendan Mills 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 1

지난 30일: 9

전체 시간: 474