Why Aren't my Quicktime Files Copying Correctly?

I just got a new flash drive that's 2 TB large, and I'm trying to copy some Quicktime files onto it. (Screen recordings, to be precise.) Shortly into the process, I got an error message saying "The Finder can't complete the operation because some data in "My File 1" can't be read or written. (Error code -36)." It cancelled the whole import process. Shrugging it off, I tried importing the files again. But once I tried that, I went to open some of them just to check if it worked. Every time I try to open a file on the flash drive, it gives me another error that says "Quicktime Player can't open "My File 1". To see if additional software is available that will enable QuickTime Player to open the movie, click Tell Me More."

This is beyond confusing. When I go to the same Quicktime files from my desktop or my documents, they open and play just fine. But when I try doing the same from the 2 TB flash drive, it doesn't work. For some reason the thumbnails don't show up either. This is incredibly frustrating, as I need to get these files onto there to clear up space on my laptop, and I can't do it if the files are going to screw up once they're on the drive. What's going on? Is it the flash drive itself, or did something go wrong with the copying process? Did the copied versions of the files get corrupted? I'm at a loss.

Each time I tried, I never touched or removed the drive, and this error has never happened to me before. I tried searching for answers elsewhere, but the only good one I could find involved the use of Terminal. This is happening on my school laptop, and Terminal is a blocked application for us, so that's out of the question.

In short: Why is this happening, and what can I do to solve it?

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요