주요 콘텐츠로 건너뛰기

기기를 수리하세요

수리할 권리

상점

모델 A1312 / Mid 2010 / 3.2 GHz Core i3 또는 2.8 & 3.6 GHz Core i5 또는 2.93 GHz Core i7, ID iMac11,3

383 질문 전체 보기

iMac shows a distorted blank/rainbow pixel screen after turning it on

iMac works when I press the shift key during start up, which then opens in Safe mode, but during a normal startup, after the apple logo disappears and leads to the login page, instead of the log-in page, a half blank white screen, with rainbow pixels distort half of the blank screen. The iMac works as expected during safe mode as the login page appears, seems normal as well as the desktop after login.

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 2

댓글:

Can you give us your exact model so we can guide you to the correct guide and needed part.

Look at the bottom of your systems foot stand to find the serial number and plug it into here: EveryMac - Lookup then paste your systems URL here for us to see.

의견 추가하세요

답변 2개

선택된 해법

Does the last four characters of the serial number contain one of the following groups (for example, xxxxxxxxDHJQ):

DHJQ, DHJW, DL8Q, DNGH, DNJ9, or DMW8

DPM1, DPM2, DPNV, DNY0, DRVP, DY6F, F610

The serial number can be found on the bottom of the stand or under "about this Mac".

해당 답변은 도움이 되었습니까?

점수 1

댓글:

Btw, I have posted a pic of my screen here: https://imgur.com/HokjRey

raven, I have not seen that type of pattern before. Hook it up to an external monitor and let us know what you get.

Thanks @mayer I will give that a shot and report back.

Hi @mayer, when I plug in an external monitor, the iMac still freezes before the login screen, but instead of a fuzzy screen with a rainbow of random color pixels, there is just a uniform blue screen (on both monitors). Any advice on what to do or suggestions on what the diagnosis could be? Thanks in advance

Try booting in Safe Mode by holding down the Shift key on start up and see if there are ant changes. Next try holding down the option key and booting from the repair partition.

4에 댓글 더 나타내기

의견 추가하세요
가장 유용한 답변

Sadly, your GPU boards VRAM has problems.

When you go into Safe Mode you are using the low resolution mode of the GPU which uses shared RAM. When you normally startup the system starts off in low res then switches into normal mode leveraging the GPU's VRAM.

해당 답변은 도움이 되었습니까?

점수 3

댓글:

Is this type of issue able to be fixed?

Can you give us your model info as it depends on what you have.

Hi Dan, it is a 27 inch LED-LCD iMac (Aluminum Unibody) bought in 2010 (this model was released in 2009 and discontinued in 2012)

@samneedshelp - Sam that still covers over 30 different models.

We're guessing here you have the Mid 2010 model. To be sure click on the blue link I posted under you question and plug in your systems S/N.

Hi @danj I am having a similar problem to what Sam reported. My iMac is an A1311 (EMC 2389) -- mid-2010 with 21.5" screen. Can you offer any tips on how to solve this issue? (Or whether it is solvable in the first place?)

3에 댓글 더 나타내기

의견 추가하세요

귀하의 답변을 추가하십시오

Sam 가/이 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 4

7일 전: 24

30일 전: 156

전체 시간: 9,990