주요 콘텐츠로 건너뛰기

Model A1238 / 80, 120, or 160 GB hard drive / black or silver metal front

972 질문 전체 보기

Why won’t my new battery charge?

I installed my new battery in my iPod 7th Gen Classic. I plug it in and it won’t charge. It just has the charge it came with new.

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요

3개의 답변

Usually battery replacing are done by professionals, but I'm not one to judge there, can you check if everything's connected properly since you installed it?

Also try different adapters and cables if you're able to.

해당 답변은 도움이 되었습니까?

점수 0

댓글:

@lenafox professionals aren't the only ones! ifixit says at the bottom of the community guidelines "Remember: It's might be easier to fix things when you've gone through five years of service training. But it's not necessary. Amateurs have changed the world!" scroll all the way to the bottom of Community Guidelines and you can see examples. on the unrelated note, good job on iFixit! I usually check on new users and I've seen you improving! keep up the good work! =)

의 답변

I guess that's true haha, sorry I didn't know, I'm still bit new to iFixIt

But everyone can still make mistakes, of course we can all do these things ourselves (Even I). Apologies for forgetting the Community Guidelines

의 답변

의견 추가하세요

@dconsmack here is the guide for it iPod Classic Battery Replacement and double check your work. always double check the dock connector. Check for bend, broken or corroded pins as well as debris. Try a new cable and try a different charger. It is possible that you have a bad battery. Try to replace it once more. It is also possible that you are having issues with the actual battery connector. It has the tendency to break of that board. Carefully double check on that. Anything past this will be related to the charging circuit on the board and schematics are not available. It would put you in the having to replace the board category.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Does the device show the Charge Indicator in the battery?

If Yes the problem is that you could have been given a defective battery, I would first check the connection to make sure It's properly making contact. If so the problem maybe the terminal for the battery itself may have been damaged, the post is fragile and It could be damaged when pulling the latch to release the battery connector. If that checks out then you have a defective battery

If It does not the issue is with the 30 pin connector itself. That connector often has a lot of lint that may need to be cleaned out. Using a very thin tool like and iSesamo and a pick can help, be careful since you don't want to damage the pins. If It's clean then the port itself is bad and needs to be replaced, that involves micro soldering.

My best advice is to buy a known good similar device if it happens to be anything involving the board, if files are an important factor just use a zip drive reader to pull files out of the device.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Todd Waetzig 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 4

지난 30일: 15

전체 시간: 512