주요 콘텐츠로 건너뛰기

모델 A1286. 2011년 2월 출시 / 2.0, 2.2, 또는 2.3 GHz 쿼드-코어 Intel Core i7 프로세서

637 질문 전체 보기

Why dose battery show 100% but will not run laptop it runs on magsafe

battery indicator flashes 5 times when pressed I have done pram and smc also w/batt disconnected magsafe is green. It has said 100% for a few days so there is on charge going to battery it shows 499 cycles

Block Image

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

답변 2개

선택된 해법

last couple times i had this issue, it was the battery failing. replacing the battery fixed the issue.

해당 답변은 도움이 되었습니까?

점수 1
의견 추가하세요
가장 유용한 답변

Not sure I follow what you mean by the battery indicator flashing five times. It only flashes one LED when the battery is low and not charged! You should press it again and see eight little LED's light up in a line. When you plug in the MagSafe cord they also will light up (maybe only a few if not fully charged).

If the MagSafe charger LED is green then you have a charging logic issue within your logic board as SMC it telling the charger the battery is charged.

How about giving us a better view here on whats happening, download this great app: CoconutBattery and paste a screenshot of the main window so we can see what its' telling us Adding images to an existing question

Did you get your system wet at some point, something spilled into the keyboard or trackpad? Or, sit your system down on a wet surface?

Update (04/10/2018)

Well as you already know the battery condition is poor (4.4%)

It's so bad it makes sense just taking it out for now. That way it doesn't interfere with your MagSafe usage. Ideally, you really need to replace it. The blinking battery tester LED's is telling you the battery is beyond hope. Your menu battery info panel is telling you the battery needs to be replaced and the blinking battery checker LED's is likewise telling you the battery needs replacement.

Diagnosing your other issues are a lot easier when the low hanging problems are removed.

해당 답변은 도움이 되었습니까?

점수 2

댓글:

Has not been wet, all the lights on battery check flash 5 times when it is pushed also when starting up there is flashing of the sleep light and I have to close lid and open it for it to start.

Also I have done the SMC reset with battery connected and disconnected I know the battery is old and it is time to replace it but the sleep light flashing and closing and opening lid to get it to start makes me unsure if it is just the battery it has been showing 100% for about a week prior to it not running on battery

의견 추가하세요

귀하의 답변을 추가하십시오

john Richardson 가/이 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 1

30일 전: 3

전체 시간: 84