주요 콘텐츠로 건너뛰기

기기를 수리하세요

수리할 권리

상점

Sony Vaio VPCSB36FG Released in 2012

2 질문 전체 보기

Laptop has to be "warm" to boot to windows but fine with Ubuntu

Hi everybody,

I try to cut to the chase. My Vaio machine has this issue for the last couple of years! and keep geeting worse that windows (7,8,10) restarts, shuts down or freezes randomly at boot, startup or in the middle of something. Sometimes with the slightest move or touching the monitor.

I have tried the thing below:

  • Cleaning the fans
  • Updating to the latest driver updates
  • Updating BIOS
  • Fresh installation of Win 7,8,8.1,10 MANY times
  • Installed Ubuntu (working just fine but it's linux)
  • Changed the HDD
  • Tested the RAM and changed
  • Tested with different chargers and batteries

Until recently when I was fed up with Ubuntu and its lack of software, I installed Windows after many tries and learned the windows only boot if the laptop is physically "warm"!

But Ubuntu just works fine if the machine is cold!

For now I have to leave the laptop is BIOS for like 10 min until the fans go crazy and then I know it would boot to Win!!

What's your guess or recommendation to try?

I appreciate your time for reading and helping me, in advance.

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요

답변 1개

선택된 해법

This is indeed a weird one!

One thing you haven't changed is the CPU. Maybe Windows uses certain instruction set extensions that Linux doesn't bother with. I presume both Windows and Linux are 64bit (or both 32 bit)?

This laptop is 5 or 6 years old so maybe you could get a replacement CPU (or entire motherboard) relatively cheaply, but you have to be scrupulously careful in reapplying the heatsink thermal paste or you'll end up with the opposite problem, of failing when it gets hot!

An interesting experiment would be to download and run Speedfan from almico.com and look at the CPU temperatures. Then go into the power settings and set it to the lowest power mode. Does it then crash when the CPU temperature drops below a certain level? Is it always warmer when you eventually manage to boot it up from cold?

해당 답변은 도움이 되었습니까?

점수 1

댓글:

First, thank you Philip for your concern and helping me.

It's weird, indeed!

Both OSs are 64-bit. I suspected MB/CPU or more relatively the AMD graphic but when installed Ubuntu and it worked fine all my assumptions were wrong.

I tried to buy the MB on Ebay but it costs 250$ so not a cheap shot with my current budget :)

Irony, I tried Speedfan before but last year and I got BOSD everytime I ran it. Anyhow, I'm going to try it again. I purposely set the fan to run at a higher temp in BIOS, in order to let the laptop gets a bit warmer at the startup (silly but I think it's working).

One thing that it's also fishy is the ACPI. Linux is not compatible with ACPI. which means it has to be off in order to run linux! on the other hand Win won't run if it's off!! Is there anyway to test the ACPI?

의견 추가하세요

귀하의 답변을 추가하십시오

Millad 가/이 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 0

30일 전: 2

전체 시간: 200