Skip to main content

Repair guides and support for televisions manufactured by Sony.

332 질문 전체 보기

Black screen, with slow flashing white LED

I have this exact issue, I have replaced all boards, Main video, power board, and T-conn, but i'm now stuck where this question left off. Black screen, with slow flashing white LED. My tv is the XBR65x850C, but having the exact same issue.

Started with not powering on,

replaced power board, nothing,

replaced video board, LED flashed amber/green

Tried to update via USB with latest firmware from sony website,

Now still a black screen with slow flashing white LED.

I'm hoping its not the panel now since I don't have many options left. Any help on this would be great!

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

We need Sony to give us the check list they have for the order process for each light code, thats what we need, some body out there who worked for these Sony people, and quick them, that know all the pros and cons, theres alot of us having this same issue, and there not helping us by telling us to buy there new and in model, problems fix, come spend another 1000 dollar bill, and eat your old tv we sold you, what ever happen to Zenith, when tv lasted 15 to 20 years,

Someone is holding the cards out there, if they have a heart or soul they would have mercy and tell us who spent hard cold money {in debt} still paying on this Sony defect, found me an old tube tv some one put out in the trash to use, Oo the year on this Tv 1991 philco, what we mess USA made. i got it out now, now i can start living again. Sorry James thanks for telling us you bought all the boards to try to fix your tv and i to were about to do the same thing until i saw your message, some day, ill set mine aside until until we finally get the right answer, Thanks

의 답변

의견 추가하세요

아이폰 배터리 수리 키트

Only $29.99

Buy Now

아이폰 배터리 수리 키트

Only $29.99

Buy Now

2개의 답변

선택된 해법

James Mckinney

you really do not have a lot of options left. You mentioned a firmware update but did not tell us why or how it ended up. Also, you are certain that your replacement boards are all good. if you still have the old board, try the old main board and see what your led shows. Your TV should have a Smart Core Red LED that should have started to flash a pattern which would have identified which board is failing.

It is possible that this is the panel itself but I would go through all the checks for the power situation as suggested by the sony fault finding flowcharts.

Fault-finding-flowcharts.pdf

Here are the steps to take for the software updates for the B-Board and the T-con board. See if these will work for you.

Block Image

Block Image

해당 답변은 도움이 되었습니까?

점수 3

댓글:

I received the amber/green light only after replacing the Video board, i went ahead and replaced the T-con board as well being unsure what the amber/green actually meant. After still recieving the amber/green light, I tried updating the tv, plugged the USB in, the light sequence changed to a blinking white LED, which seemed to mean updating. My USB stick also has a Red LED built in when it is being accessed. Updating took quite a while before the White LED went from a steady flashing white, to a slow dim, in/out. Thats where the TV is at now. Turning the tv on/of, plugging/unplugging just results in the slow dim on/off. No picture on the screen just the dim LED. I'll try your suggestion and use the old board.

의 답변

As far as i am aware the boards are good, just ebay replacement stating 100% tested and working. Though i have the tools and parts, my knowledge on actually fixing the tv is minimal. Even figuring out the Multimetter took a little time. As far as the "smart core Red LED" goes, i'm not sure what that is or where to look. From the inital problem the TV LED was dim lit white,black screen, (replaced boards, amber/green-blinking white-dim flashing white)Still no screen. Thanks again for the help, i'll try to decipher the flow charts and see where it leads as well.

의 답변

since your LED is white it appears as if part of the roblem could be the update for the boards.

의 답변

So I've tried putting the old Video board back and there is no LED illumination at all, Replaced with newer board and the LED illuminates, but its a light white to dim, then off and restarts. Its almost like a power loop, but I'm not 100% sure This White LED reboot sequence only started after I tried to update the firmware per USB. Prior was a the amber and green blinking light. Still no picture throughout all of these changes.

의 답변

I thought it was just a reboot due to the update malfunctioning, but after attempting to factory reset the tv, the reboot continues to happen throughout the reset as well. So i'm guessing its something internal causing the TV to reboot. I've tried putting the old Power and Tcon boards back, but the problem still persists. I'm at a loss.

의 답변

10에 댓글 더 나타내기

의견 추가하세요

Did you ever solve the problem? I am having the same issues. I’ve replaced the power board and main board, but still only get the white flashing LEDs from the remote. At a loss as to what to do next

해당 답변은 도움이 되었습니까?

점수 0

댓글:

yes i did and i have also made a video https://youtu.be/PqTedRUGr44

의 답변

의견 추가하세요

귀하의 답변을 추가하십시오

James Mckinney 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 9

지난 7일: 86

지난 30일: 408

전체 시간: 2,432