Display + Restore Problem

Guys i’m having problems with an IPOD classic 80 Gb.

It was working fine, i decided to install a Iflash adapater, so i opened it, did my things but now it doesn’t turn on, i mean the screen stays black.

So i replaced it but i’m still getting the same problem,

When plugged on Windows it’s being recognized, i’m getting the sound when something’ plugged on the USB ports.

Even itunes recognizes it, but then i’m getting a message saying that the itunes server does not support this version. So impossible to restore it, tried disk mode too but no good.

I changed the Sata ribbon, put the original hard drive, tried another clickweel, another lock switch + heaphone, another battery, cleaned everything with isopropyl alcohol but still the same situation.

Tried another cable, another usb ports, another computer

It’ frustrating to not know what the screen is showing.

Side note : I’ve tried to follow https://www.freemyipod.org/wiki/Restore_..., it’s being recognized as a DFU device but i do not get the same PID as the tutorial, anyway i’m desperate.

Am i having a motherboard problem ? I’m having a doubt as it’s recognized on windows.

Hope someone can help.

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요