주요 콘텐츠로 건너뛰기

2012년 6월 출시 / Core i7 프로세서 Turbo Boost 포함 / 최대 1 GB DDR5 비디오 RAM

595 질문 전체 보기

New iFixit battery, installed ok but drops charge extremely fast..

Hi All,

Just installed a new iFixit battery into my Mid-2012 15” Unibody MBP.

Also replaced the DC in board and a new Apple 85W MagSafe charger.

The battery is recognised and seems to work fine. However, when running on battery power the battery percentage drops down to around 50% after an hour or so and then all of a sudden it will drop from 50% down to 7% instantly. The computer will run for maybe an hour at 7% then will drop down and eventually shut down at 0%.

I made sure to follow the calibration instructions to the tee, charging to 100% running it on the charger for a few hours then unplugging the charger and draining the battery until the computer shutdown. I then left it overnight with a flat battery and recharged it to 100% the following morning.


I have reset the SMC, reset PRAM. I am also using a new 85W MagSafe adaptor.

Could the battery be faulty? 

Thanks in advance,

Luke

Update (04/15/2019)

Thanks for the replies guys, I do get about 3 hours of use from the new battery, It seems to go OK from 100% to around 50% but it just drops from around 50% to 7% within a minute or two, then sits at 7% for about half an hour then I maybe get another half hour of battery life before the computer turns off.

It has taken over 6 hours to charge it up today, much slower than yesterday (full charge in around 3 hours)..

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 7
댓글 3개

Just a quick update, iFixit are sending out a replacement battery for me. Sounds as though there is a fault with the current battery.

I have been extremely happy with their support and service.

Hope the replacement battery solves this issue.

Will keep you posted.

Widespread issue. I bought batteries from ifixit (for iPhones), and each one of them had issue after very few cycles, sometimes right from the beginning. 80% reported health after 60 cycles, battery dying at 50% in a moderately cold weather (-5), then slowly filling with gas after 100 cycles, pushing the LCD outward. As iPhones do use lots of battery power, hard to tell whether it is a bad battery or simple aging.

On the other hand, Apple-manufactured batteries are overly optimistic about their health: they still report 85% after 500 cycles, but still discharge pretty fast.

@pat have you ever contacted iFixit about your experiences? I do know that they actually test all their batteries etc. If there are any issues I think you should notify them so they can take a look at what is going on. https://help.ifixit.com/article/136-emai...

댓글 달기

답변 1개

가장 유용한 답변

sounds like you might have a faulty battery.

Best app you can use to get a reading of the battery health is ‘Coconut Battery’

get a screen grab of the test screen on that app, then email them direct.

I’ve seen quite a few replacement (non-apple) batteries have issues like this, and it is nearly always a fault with the battery.

In some cases, the battery shows a full charge capacity of over 60,000 (which is physically impossible), and it powers off after a few minutes on without mains plugged in.

OWC batteries have this issue from what i’ve seen, as we sell a lot of them.

해당 답변은 도움이 되었습니까?

점수 4

댓글 2개:

@thebookyard - Jon, this is a QC issue at the battery factory. There seems to be a rash of bad batteries from many different sellers. Another case of Apple not offering parts directly.

@thebookyard *Newer tech

Instead of OWC Batteries

댓글 달기

귀하의 답변을 추가하세요

Luke Marinovich 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 1

7일 전: 2

30일 전: 3

전체 시간: 480