New Aura Pro X2 SSD - Can't restore macOS

I purchased a new Auro Pro X2 SSD via ifixit, installed it per the instructions (which was very easy). When I boot up to install macOS Catalina it always fails. I’ve tried everything I can think of — internet recovery, using a bootable usb drive I created before the install, and restoring from a time machine backup on an external drive. Every time when there’s ~10 minutes left the screen goes black, and eventually gives me the generic error message that something went wrong with my mac and it’s restarting.

A few notes:

  • My old SSD was fully up-to-date with the latest version of Catalina before I uninstalled it and installed the new SSD.
  • I did format the new SSD prior to the install. I’ve tried both Mac OS Extended and APFS formats.
  • I’ve tried resetting the PRAM and SMC, doesn’t help.
  • Now with my latest attempt, I can’t even get my macbook to boot up with the new SSD installed — it just turns on to a black screen no matter what key combo I hold down during the power cycle.
  • Finally, I’ve run first aid on the new SSD and it always comes up 100% fine.

I’m 99% sure I need to return the new SSD for a replacement, as it must be faulty given everything I’ve tried above. I’ve also reinstalled my old SSD and it works perfectly, so I don’t think it’s anything with my macbook itself.

Anyone have any other suggestions or ideas I could try?

Thanks in advance!

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

Never mind, I chatted with OWC and they concluded the drive is faulty and needs to be returned.

의견 추가하세요