My iMac EMC 2638 freezes and shuts off, is this a hardware issue?

Hi there,

I’ve recently purchased an iMac late 2013 that has taken to shutting down randomly. I’m wondering if this is a hardware issue, or if I’ve altered something that’s now going wrong.

Usually the iMac will turn off at least once during the day, most often about 10 min after I first power it on—I’ll just have got started on working on something or opening my email, and then the screen will turn black for a second, turn back on without the mouse and hold for a few seconds, and then either show the grey screen with a spinning wheel for a couple of seconds and turn off, or just skip that and turn off.

When I then turn it back on, all the windows I had open before reopen and the iMac will then usually work fine for the rest of the day. Though sometimes it can repeat this maybe 6 or so hours after the first one.

I’m not sure if this is down to a power failure (because I’ve the iMac set to immediately turn back on after one, which it doesn’t when this happens), or if it’s something to do with the hibernate mode gone awry. When I first got the machine, I changed the pmset hibernate mode to hibernate instead of sleep mode, but the time for the machine to wake back up got annoying so I changed it back to the default (0). These are the current stats from pmset -g:

System-wide power settings:

Currently in use:

 standby              0

 Sleep On Power Button 1

 womp                 1

 halfdim              1

 hibernatefile        /var/vm/sleepimage

 powernap             1

 gpuswitch            2

 autorestart          1

 networkoversleep     0

 disksleep            10

 standbydelayhigh     86400

 sleep                10 (sleep prevented by sharingd)

 autopoweroffdelay    28800

 hibernatemode        0

 autopoweroff         1

 ttyskeepawake        1

 displaysleep         10

 highstandbythreshold 50

 standbydelaylow      86400

I’ve just reset this to default through energy saver settings, but is there a means for me to test what might be the problem, or if this may be caused by the power unit, or if this is just some software issue?

Thanks for your help!

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기