Home button non-functional after IOS 13 update

Hi all,

I have a really weird issue here with the home button on my beloved SE. After encountering some bizarre email issues, I was left with no choice but to upgrade to IOS 13 (I was on IOS 9 - don’t judge me, I have a mistrust of updates on old devices).

Everything was working fine on IOS 9, after the update all seemed OK, but the following day my home button slowly became more and more unresponsive until it stopped working, though touch ID is fine. I tried a restore and 2nd recovery from backup, but the problem remains.

Obviously I suspect the upgrade is the cause - I did notice the phone running hot and draining the battery after the 2nd restore and I turned off battery management which solved the problem. In order to rule out hardware problems I opened it up and reseated the home button connection and when that didn’t work, I connected a brand new home button, which also failed to work.

So, my questions are :

1) Could the overheating caused by the battery management have damaged something other than the home button assembly - the fact the button slowly died makes me think this could be the case? If so, is it repairable?

2) Could this be a software issue, and if so, how can it be addressed without DFU mode?

3) Has anyone else encountered this problem and found a solution?

I should note that I have performed several repairs on this phone - 2 x battery replacements and a dock connector replacement. Id really like to get it fixed rather than junk it.

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요