Black screen and no chime iMac 27”2015

Hi, I read so much on this and tried various things but still have the problem so here’s what’s happened and what I’ve done:

Back in February I unplugged the iMac to move to another room, but didn’t realise it was in sleep mode, the uk 3 pin plug sparked as I pulled it out the 4 way extension (None surge). When powering up it had a box with a question mark in. Eventually I managed to get OS X working, but the sound wouldn’t work. When trying to update to latest OS X it would always fail, error message. Stuck on the OS X that came with the MAC meant I couldn’t use the latest apps etc… plus the sound still didn’t work just made a loud cracking sound when adjusting volume…

So I thought maybe the hard drive was the issue, went to remove screen and cracked it slightly at the edge, doh!! The screen still worked fine but decided Id put the Mac to one side for a bit….. six months later I decided let’s have another go.

so two nights ago removed screen, all fine this time! Removed 3.5” HD replaced with a known working one, plugged screen back in, turned Mac on to nothing, just the fan starting up and hard drive spinning, led 1&2 lit but 3&4 off.

When I plug the Mac in it starts up straight away, no need to press PWR button? Don’t remember it doing that before. No chime either.

i took the logic board out tonight and replaced the BR2032 battery just in case that had something to do with it, but nothing.

ive removed the ram, and reinstalled in different combinations, still nothing

removed ram, kept finger on PWR button then plugged it in, released pwr button, fan started up really fast, unplugged pwr cord, put ram back in, plug cord back in and still no difference.

reset pram - but not sure if keyboard is charged, leaving it over night to charge. I noticed earlier when pressing caps lock green light doesn’t illuminate.

ive even put original hard drive back in just incase, but still nothing.

Is there anything else I can try, or is it looking like a knackered logic board damaged from when I initially unplugged it? I tried looking for a fried inductor on the logic board, but all seems ok, I did see a post on an earlier model inductor L9000 Damaged causing screen not to work.

hope someone can help

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기