Cannot turn on in certain situations

My iMac was originally a 3TB fusion drive but I removed the HDD and replaced the Apple NVMe blade with an ADATA SX8200 Pro. Here’s all the details of the iMac:

Mac model = iMac17,1

Logic board ID = Mac-B809C3757DA9BB8D

EFI 428.0.0.0.0;

macOS Version 10.15.7 (Build 19H2)

The ADATA SX8200 Pro uses a Sintech adapter that has the protected contacts so there’s no issue with shorting contacts to the blade socket.

After the upgrade I had trouble getting the iMac to power up - I mean literally nothing happened when I pressed the power button. I checked the power button was working and even replaced the ribbon cable between the power board and the logic board, but it wouldn't ‘t power up. Only the first diagnostic LED was on. I eventually got it to turn on after leaving it for about a day completely unplugged from the power as well as removing the RAM and all peripherals (USB, ethernet, DisplayPort, etc). After this time and putting just the power cable back it just powered up right away and I was able to install Catalina, restore from backup and was up and running. The speed of the NVMe blade is really fast and I had no issues at all in using the iMac … unless I powered it down.

A while later I restarted the iMac but didn’t immediately log on and left it overnight not thinking that the problem would happen again. The next morning it wouldn’t power on - exactly the same problem. So I left it completely unplugged from power and peripherals for 2 days (I was using my MacBook Pro) and lo and behold I was able to power it up again using the power button. Weird. So I tried to troubleshoot. I powered down the iMac, waited a few minutes and then tried to power it on - and got the same issue (couldn’t power it on). So I took it apart and removed the NVMe blade and reseated it. It powered up straight away using the power button. I reset the power options in system preferences back to defaults. Powered off, waited a few minutes and it wouldn’t power on. So I took it apart, removed and put back in the NVMe blade, put it back together and it powered on no problem. I kept it on and let it sleep but never switched it off and it has been fine for about a month. Then I let it restart, made a coffee and forgot about having to log in straight away, and it won’t power on again.

So instead of keeping on this cycle of taking the iMac apart all the time to take out/put back the NVMe blade I thought I’d see if anyone had come across this and can offer a more permanent solution.

It appears that there isn’t any firmware update available for the ADATA SX8200 Pro but I’m thinking that it may well be a firmware issue - that the ADATA SX8200 Pro has some odd power management issue that prevents the iMac from being powered on.

Thoughts?

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
댓글 달기