주요 콘텐츠로 건너뛰기

모델명 A1707. 2017년 6월 출시, 이 MacBook Pro는 Kaby Lake 프로세서 최대 2.8 GHz 쿼드코어 Intel Core i7 프로세서와 Turbo Boost 최대 3.8 GHz를 사용합니다.

270 질문 전체 보기

broken locking flap for the battery board data cable

Broken the locking flap on the zif connector for the battery board data cable when I tried to change the screen, is there any way to fix it?

It’s a MacBook Pro 15 inch 2017

Block Image

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 3

댓글:

Do you still have the latch? Post a few pics of it so we can see if its still good Adding images to an existing question

Thanks for your reply! Unfortunately the latch is broken into two pieces is will it not work without the latch? I tried putting the cable in place and holding it in place with tape. But the computer does not find the battery.

Hi, I have the same issue, the 'latch' juste came butv is still in one piece. How am I supposed to re-attach or re-insert it properly?

댓글 달기

답변 3개

선택된 해법

@gabriel111 - You need the compression of the latch.

Sadly, I haven’t found a source for this connector. Your only hope is finding someone who fixes Mac’s who has a junker to take the latch from.

해당 답변은 도움이 되었습니까?

점수 1

댓글:

I have a water damaged MacBook Pro that I can take the latch from but I don’t know how to connect back the latch, because it first fell out when I tried to close it, and was broken into two parts when I tried to put it back in place, it’s very small

@gabriel111 - If you look carefully at the latch and the body of the connector you can see how it snaps in.

If you can't tell I think you'll need to find someone local who has a bit more skill to help you.

댓글 달기
가장 유용한 답변

I have a solution that worked for me – should work for you too!

I accidentally broke my retaining flap as well on the battery board data cable connector.

What fixed it: I used the black pull tab on the battery cable and removed it and put it underneath the end of the cable that was missing the retaining flap. I didn’t put the adhesive side “head-first” into the socket, i put the side without adhesive “head-first” and used the adhesive to connect it to the underside of the cable. Then I slid the cable end + pull flap underneath into the socket and used a piece of tape over the cable and connector and over where the flap would have been, and secured the other end of tape onto the logic board – it seems to have enough pressure from underneath to do the trick!

My 2017 MacBook Pro 13” Touchbar (A1706) now sees the battery and is running on battery power alone!

Sorry if my explanation wasn’t very clear – let me know if you have questions!

해당 답변은 도움이 되었습니까?

점수 3

댓글:

I saw on your photo to you don't have the black pull tab on the cable. You should be able to carefully cut a thin strip of electrical tape (maybe not because we don't want the adhesive stuck in the socket) OR you can try a thin piece of plastic from a retail package. Make sure it's about as wide as the cable. use electrical or Kapton tape to connect the strip to the cable on the underside. Follow the rest of my recommendation by securing it all once in place with another piece of Kapton tape or other tape.

Hey, I had this same issue. I followed your instructions — I think another way of putting it is that you’re building up the battery cable thickness so the connections are pressed more firmly into the locking tab from below — and it worked!

Thank you! I’ve missed my little A1706 pal.

댓글 달기

I had this exact same problem. After having to replace the screen on my 2020 MacBook Pro 13" having thrown coffee over it, it wouldn't power on. However, I researched and found this article.

It turned out that ribbon cable had broken, presumably internally, and when I flipped the compression latch up on the larger of the two ends, it somehow let go and launched itself into orbit never to be seen again!

I ordered a new cable from Germany along with some Kapton tape. I shimmed the end of the ribbon cable with two pieces of Kapton tape and using tweezers, persuaded the cable into the connector (okay, I admit the wrong way up first time, second time lucky!) At this point I turned the laptop over and powered on.....nothing. I did wonder if the battery had run flat, unlikely but not impossible, so I connected the power cable and of course it powered up. The difference this time was a battery icon on the display whereas before there was no icon and the display was multicoloured flashes and full speed fans etc. The battery was now showing 100% so I guess it needed a 'jump start' using mains power.

It's now happily reloading Monterey and I'm hoping all is resolved.

Thank you for the above, it inspired me to have another go at repairing the old girl, though what I will do with it I'm not sure as I replaced it with a new 14" MacBook Pro. Maybe some lucky soul on eBay.......

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

Gabriel 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 2

7일 전: 20

30일 전: 109

전체 시간: 848