PSP 1004 will not charge with official battery charges

In the last few days I found at my mom place my old PSP 1004. I decided to use it again and try some old game I played when I was young.

So, when I tried to plug the official battery charger the PSP won’t charge, no lights at all. After a while I found a sort of power cable, USB-A to DC 5v, and I give it a try. I can see the orange light and the PSP tunrs on, the device doesn’t recognize the battery (it gives me an external battery signal) but I am just happy it’s functional and not broken.

So I thought the battery or the power charger are broken, I have tried with a multimeter to test the battery (no signal) and the power charger (I really can’t make the multimeter work with the power charger, the plug is too small for the mutimeter to give me any feedback).

Anyway, I decided to buy another original power charger. I tried it, doesn’t work, no lights agian. So, 2 different original power charges didn’t work at all.

Maybe it’s the battery I think, and I bought a new one. With the new battery inside, the official power charges don’t work, no lights again. The USB-A to DC 5v cable instead it’s working, I don’t know if it is capable to charge a battery (I' am testing it right now) but the PSP recognize that is charging the battery. However I bought on amazon even a wall Portable Rechargeable Battery Charger (I will receive it tomorrow).

My questions are:

- What is demaged? I can’t understand.

- How can I make work an offical adapter with my PSP? I refuse to think 2 original chargers on 2 are broken, and 1 one them is new.

I really don’t know what to think, at this point any help could be really appricieted.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기