Why is my PSP not turning on, but showing the green power light

For a more thorough explanation and the steps I have already tried:

  • The console was noted as not working and untested
  • When examining the console before repair-
    • Swollen battery
    • Noticeable crack above the memory stick port
    • Missing silver lining plastic along the left side of the console above the memory stick port
    • Small amount of dust behind screen
  • Beginning MINOR repair-
    • Battery was replaced with brand new 3.6-volt, 2600-MA battery
    • Brand new charger was purchased and tested on console
    • Geen light power indicator was on with NO audio or screen light
    • Possible brick was assumed, and all following button combinations were tried
      • Power switch on + L + R
      • Power switch on + L + R + Home
      • Power switch on + Home
      • Power switch on + L
      • Power switch on + R
      • Power switch on + L + Home
      • Power switch on + R + Home

I began teardown following both the Ifixit PSP 1000 teardown article and Robles Junior PSP 1000 disassembly video. No corrosion on the motherboard, memory stick board, and power switch board was seen. All ribbons were removed successfully without tears or accidental bends. All assumed problems are believed to be around the memory stick board as after teardown the plastic tube above the board that holds the memory stick (if you turn the back plastic shell on its back its where the top screw when you first begin disassembly is located) broke off from the back shell piece. After removing the memory stick board, I noticed that the small metal piece that holds the board was completely missing. No other pieces or screws were missing from the console. After teardown I reassembled the console enough to see a response. The only pieces not assembled were the bottom bar (home and volume), plastic door tray, and top shell piece. After inserting the battery and turning on the console, the screen did come on and respond to left, right, up, and down commands as well as the triangle, circle, x, and square buttons. After inserting a game, the screen showed it was unable to read the disc. After attaching the mention pieces that were unassembled for the test run another final test showed the green power indicator with the screen showing light; however, it was completely black. I hope this serves as a good explanation as I want to be as detailed as I can. Thank you for taking the time to read this and have a good day!

P.S. before I forget, the audio had no noise and I have ordered a shell replacement to see if this may be the possible problem. In short of the whole big explanation, I think the system is possibly overheating due to the missing metal piece that holds the memory stick board in place. I haven't seen any listings on ebay, amazon, or the ifixit store for this piece though.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1

댓글 1개:

I have about the same problem on a psp model last Rev e1000. Except mine had no internal accu to test or rebuild. Got original power adapter,but nothing.only led. Not sure what to try. Does it need battery pack to boot?or power adapter 5v Sony is enough....

댓글 달기