주요 콘텐츠로 건너뛰기

The Samsung Galaxy A40 was released in April 2019.

31 질문 전체 보기

Device Screen is black and shows no sign of life

One day I was listening to music on the phone when it suddenly started vibrating and died. The screen was black and did not want to turn on again. However when I plug it into my pc and attempt to power it on whilst running lusb (debian Linux) the device comes up as Samsung Electronics Co., Ltd Exynos7885 for about two seconds before disappearing. How can I go about fixing and troubleshooting this?

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기

답변 1개

가장 유용한 답변

Hi Zoe,

First, I would remove the SD card (if you use one) and the sim card. I had some corrupt SD card files that messed up the entire OS.

As a second step, try a hard reset. Maybe the Android phone is just stuck. How to hard reset: 1) press simultaneously power + volume down and keep them for 5-10 sec until phone, until phone display the Samsung logo. 2) press power and volume up simultaneously until it displays the debug menu. There is a slight chance for this to work in your case, but it is the easiest thing to try. If this works, then Reboot System now. If after reboot is the same, I would try again hard reset and then "Wiping data/factory reset", but this will erase your data.

Third, if the phone doesn't power up using the hard reset, I would try to charge it and check if the battery is warming. If it does, you have a clue that the battery might be ok.

There is also a way to re-install the Operating system by connecting the phone to a computer, but this is not applicable since it is visible for only a few seconds.

If the phone had a recent big fall or made contact with liquids, that might cause it. Or if you've noticed that the phone was warming up excessively during charging, it could indicate the battery or charging port.

I suspect the battery or the mainboard, but it is just my supposition. Let us know if any of this works and if you are interested in fixing it your self.

Good luck,

해당 답변은 도움이 되었습니까?

점수 1

댓글 3개:

Would a dead battery that won't charge cause the symptoms I described I feel this may be the case due to a night of charging causing no temperature change in the battery. Furthermore the fact it connects if only briefly when the power button is pressed indicates to me that it could be a lack of power issue?

@zh261 It's hard to tell if is the battery, mainboard, or something else, only from these details.

Have you tried the Hard Reset or removing the sim and the SD card (if any)?

Yep, I replaced the battery and absolutely nothing changed, any other ideas? Also interestingly something has changed however- now when run lsusb -v it tells me:

Bus 002 Device 016: ID 04e8:1234 Samsung Electronics Co., Ltd Exynos7885

Device Descriptor:

bLength 18

bDescriptorType 1

bcdUSB 2.00

bDeviceClass 0

bDeviceSubClass 0

bDeviceProtocol 0

bMaxPacketSize0 64

idVendor 0x04e8 Samsung Electronics Co., Ltd

idProduct 0x1234

bcdDevice 1.00

iManufacturer 1 S.LSI, SEC

iProduct 2 Exynos7885

iSerial 3 ************

bNumConfigurations 1

Configuration Descriptor:

bLength 9

bDescriptorType 2

wTotalLength 0x0020

bNumInterfaces 1

bConfigurationValue 1

iConfiguration 0

bmAttributes 0x80

(Bus Powered)

MaxPower 500mA

Interface Descriptor:

bLength 9

bDescriptorType 4

bInterfaceNumber 0

bAlternateSetting 0

bNumEndpoints 2

bInterfaceClass 255 Vendor Specific Class

bInterfaceSubClass 0

bInterfaceProtocol 0

iInterface 4 USB Booting v0.5

Endpoint Descriptor:

bLength 7

bDescriptorType 5

bEndpointAddress 0x81 EP 1 IN

bmAttributes 2

Transfer Type Bulk

Synch Type None

Usage Type Data

wMaxPacketSize 0x0200 1x 512 bytes

bInterval 0

Endpoint Descriptor:

bLength 7

bDescriptorType 5

bEndpointAddress 0x02 EP 2 OUT

bmAttributes 2

Transfer Type Bulk

Synch Type None

Usage Type Data

wMaxPacketSize 0x0200 1x 512 bytes

bInterval 0

Device Qualifier (for other device speed):

bLength 10

bDescriptorType 6

bcdUSB 2.00

bDeviceClass 0

bDeviceSubClass 0

bDeviceProtocol 0

bMaxPacketSize0 64

bNumConfigurations 1

Device Status: 0x0000

(Bus Powered)

whether this helps I don't know

댓글 달기

귀하의 답변을 추가하세요

Zoe 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 10

30일 전: 74

전체 시간: 624