Output/Input Error when Installing new Internal Hard drive

2.0GHz MacBook mid 2007

My Internal HD crashed a couple months ago, so I bought a WD Scorpio Blue 320gb Sata HD.

After I installed the HD, I went into the Disk Utility to try and format it and I get an input/output error (log says "error \n" ) . CAN ANYONE HELP PLZ ??

Note: I do not have the original software CD's, so I used the software disks from a friend

(she had the same issue with her Macbook *black version*, but she followed the same steps I did and it worked).

I also ran a "hardware test" and everything was fine.

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

Make sure your new hard drive has a GUID partition created with Disk Utility.

의 답변

I tried the GUID partition but I still get the same error.

의 답변

의견 추가하세요

2개의 답변

선택된 해법

Connect your macbook to your friend's macbook with a firewire cable then boot your MB while holding down the T key on your keyboard and check if your HD mount on your friend's desktop or if you can see it with Disk Utility. If so try to format and install OS with source machine.

Or remove your HD from your MB, put it in an external 2.5" sata enclosure and try to format it with your friend's macbook.

해당 답변은 도움이 되었습니까?

점수 4

댓글:

+ Along with all of lemerise's good advice, I would make sure the jumper on the drive is set for 1.5GBs and not for 3GBs.

의 답변

의견 추가하세요

I bought the wrong firewire cable, so I will make sure to update the forum once I get a chance to try out your suggestion

I am not sure how to set the jumper on the drive, do you mind explaining how to do this? (this is my first time trying to repair my computer I am not very knowledgeable on the subject)

Thanks for all of the help!

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Mary 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 1

지난 30일: 8

전체 시간: 1,900