Skip to main content

5세대 iPhone. 수리는 간단하며 스크루드라이버, 비집는 도구 그리고 인내가 필요합니다. GSM/CDMA / 16, 32, 또는 64 GB / 검정색 또는 흰색.

2996 질문 전체 보기

Mic not working after dock connector replacement

I was having issues with in-app sound, basically seemed like the phone always was in "dock-mode", so I wouldn't be able to play sound from apps through the speakers. I did restores/resets/cleanings/etc and I couldn't get it to work.

So.. I bought a new dock connector, and replaced it. I switched over the rubber microphone piece when I did the install. The new connector seemed like a success at first, the phone charged, played sound, did everything just find, UNTIL I made my first phone call and the person on the other side could not hear me.

I thought maybe the rubber thing wasn't positioned well, so I took it off and made a call without it on. It worked just fine. I thought "Great, it was just the rubber thing out of line."

I reinstalled, making sure I was very careful about the placement of the rubber mic piece. Made a call-no mic.

I have since tried it on/off, wiggled, cleaned, etc. and I am getting NOTHING from the mic.

Am I missing something or was this dock connector just bad?

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
의견 추가하세요

아이폰 배터리 수리 키트

Only $29.99

Buy Now

아이폰 배터리 수리 키트

Only $29.99

Buy Now

5개의 답변

가장 유용한 답변

I found a tiny, invisible piece of protective plastic on the mic (not the shiny gold side--the other side). When I removed it & reassembled, it all worked perfectly.

해당 답변은 도움이 되었습니까?

점수 1

댓글:

After taking my iphone 5 apart three times in total (the first charging port/headphone assembly was faulty) this was the solution that worked for me. As teh film was not a blue tab I did not believe it needed removing. I thought it was sticky to stay stable within the microphone rubber housing. Thanks!

의 답변

Thanks. Can you please provide additional detail on the film? I have a similar problem with my mic after replacing the dock connector. I opened up the phone a second time to look for the film and remove it, but I found nothing on the aperture of the rubber housing.

의 답변

의견 추가하세요

Sounds like the mic boot or the boot holder is clogged with debris or the bottom mesh is clogged. The mic worked when sound could get in around the black plastic mic boot holder. I have fixed several with this problem usually construction workers who get alot on dust and debris flying around.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

I've got the same problem before and after replacing a dock connector for a coworker. He didn't stick around or share the pass-code for me to test so I didn't know about the mic problem until he returned complaining about it a short while later. He couldn't leave the phone with me and didn't have the time for me to take a look, but I found people reporting DOA (dead on arrival) mics online and figured that we'd get another replacement to try again.

Anyway, rather than just swapping them out a few times like I've seen some do, I'm going to do my best to make sure it's a bad part and not an installation issue.

First, there were some minor differences in the replacement part. I'm not talking about a lack of epoxy over SMT components or no Kapton tape over the screw or no rubber bits in various places; I'm saying that there were differences in the traces and such. One example: The original had a bit of that conductive grounding fabric stuck on a grounding plane on the flex cable where it folds around the side, bridging it to the the frame of the phone. The replacement didn't have a grounding plane on the flex cable to transfer it to. I'm guessing the design was revised at some point. Other possible issues: There was adhesive holding the original microphone in the rubber boot. The replacement seemingly had none. Now I wonder if I simply didn't notice that it did have some with a tiny bit of backing film that wasn't removed. Alternatively, some of the previous adhesive may have remained inside the boot and may have folded over the hole during removal/insertion.

Strangely, though speakerphone uses the secondary/noise-canceling mic, voice recorder does not. Is this a change from iPhone 4 behavior?

Edit: Another possibility: The finger that contacts the back panel that is secured by one of the two screws that holds down the battery connector was broken off by whoever did a previous repair. I doubt it's relevant, but perhaps some circuit is not complete without at least one of those two ground connections.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Same issue here.

Was having problems with my sound/speaker, therefore I ordered a new dock and replaced it all carefully.

Everything was also fine until I went to make a call and the person at the other end couldn't hear me. If I use speaker phone, all is well, but that is VERY inconvenient when calling in a noisy or public place.

I just finished tearing my phone apart again to make sure that I had properly reconnected everything etc.....

I'm not sure of what the actual fix is in this case. Once again, do I have a faulty replacement part? Or did I miss something?

Either way, the repair fixed 1 problem but seemingly caused me another. Any suggestions as to what to try?

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

After taking my iphone 5 apart three times in total (the first charging port/headphone assembly was faulty) this was the solution that worked for me. As the film was not a blue tab I did not believe it needed removing. I thought it was sticky to stay stable within the microphone rubber housing. Thanks!

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Andrew Woods 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 0

지난 30일: 2

전체 시간: 3,687