Transferring Touch/Click Wheel Electronics

To preface my question...I have quite a bit of experience working with various iDevices. Taking them apart, fixing them, replacing parts, putting them back together etc. My point is that I'm not a newbie to this sort of stuff.

With that said, I recently undertook the task of refurbishing the first iPod I ever owned...a 3rd generation. Originally, I was just going to replace the battery and call it good, but then I got into completely refurbishing it and installing a compact flash replacement HD. Yeah, I know, strange to do so much to such an old iPod, but it has some sentimental value and I just love doing this sort of thing. Generally, things had been going pretty well with it until today.

I ordered a replacement front panel from iFixIt, knowing full well that the one I ordered did not come with the electronics for the touch/click wheel. Although I couldn't find any information on how to do that transfer, it seemed pretty straight forward. So when I got the replacement front panel, I took my old panel (which was fully functional by the way), slowly and carefully heated it up to make removing the electronics easier, and eventually was able to carefully remove the electronics. I did my best not to bend anything.

After installing the electronics from my original front panel into the new front panel, then attaching the logic board, etc. it booted up just fine, but the electronics didn't respond properly. I wasn't able to use the scroll function at all, and the other buttons only worked intermittently.

Here are some things I have already tried:

- Happened to have another front panel kicking around from a unit I bought on eBay. Removed those electronics only to find the same result: intermittent functionality.

- Unhooked the battery, and restarted. I would love to be able to do a hard reset, but can't since I don't have buttons that function well enough to do so.

- Used alcohol to clean the inside of the new panel and make sure there is no oil from my fingers there. Also used some alcohol to clean off some of (but not all of) the adhesive from the buttons. No change in functionality.

- Tried using the electronics while removed from the front panel. My original electronics didn't work at all now, and neither did the set I bought on eBay. I did a battery restart and boom, all of a sudden the eBay electronics came to full life. Shut down again, installed into the front panel, back to intermittent functionality. Took it back out of the case...no luck.

- Tried using a spare click wheel flex cable that attached the click wheel electronics to the logic board. No change.

The one thing that I haven't done yet is a software restore. Given how everything has gone so far, it seems like it could very well be a software issue...perhaps the logic board has to have a chance to "recalibrate" itself to the touch wheel? I dunno, but once I get access to my Mac with a firewire 400 port again, I'll try a software restore and post how that goes. In the mean time, I figured I would put something up here in case someone else had some experience with this.

Thanks in advance for any help you can give me!

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

Realized that I had an old HP PC with a firewire 400 port kicking around. Used that to restore the iPod...no luck. Still intermittent functionality with the eBay electronics, and no functionality with my original electronics.

Starting to wonder if they electronics are really just that fragile. The board seems pretty solid though, and doesn't seem like it would be damaged that easily...

의 답변

Have you tried it with the old hard drive?

의 답변

Good question...I have. I should have mentioned that the setup I've been working with is all original parts except for the front panel.

의 답변

의견 추가하세요