주요 콘텐츠로 건너뛰기

iMac Intel 27" EMC 2309 (Late 2009, Core 2 Duo 3.06 또는 3.33 GHz) ID iMac10,1, EMC 2374 (Late 2009, Core i5 2.66 GHz 또는 Core i7 2.8 GHz) ID iMac11,1

467 질문 전체 보기

CPU Fan runs at full speed.

Hi, the CPU fan of my iMac is running at full speed. iStat says it's not running (0rpm). The temperatur sensor is working, my ASP says, that's a problem with the logicboard. Any resets (SMC, PRAM) are done but this problem is still there. I just bought an external fan control but first I want to ask if somebody know the pin assignment of the CPU fan plug.

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 14
댓글 4개

Has the hard drive ever been replaced?

Nope only the fan has been replaced.

Many thanks

I found this page while looking for answers to the fan running fast problem.

The resistors can be found in the UK on eBay if you do a search surface mount resistor 47k ohm

Got mine here


You get a hundred of them but you will need a few as they at so small you lose them .

@gunar0585 como resolveu? meu imac ano de 2010 só fica com a ventoinha em rotação máxima

댓글 달기

답변 13개

선택된 답변

Something is not right here with iStat. Do you have the older widget or are you use the current version? Give Temperature Gauge a try, does it show the samething? Lets see what the second tool tells us.

The fan speed sensor is part of the fan unit so you may need to replace it. I don't see the logic board as the issue here, pending what new info you can tell us.

해당 답변은 도움이 되었습니까?

점수 2

댓글 10개:

Well I tried smcFanControl like this guy here: CPU fan runs full speed

But with no success. This tool shows me 0rpm too, I installed the SSD Fan Control tool to have a look if the temperature changes when I turn up the HDD/Optival fan. Yes it does even the CPU Temperature is changing a bit.

The device was at a ASP last week because the graphics card was broken. They tested the device, found a broken HDD fan they renewed it an then, they say that the CPU fan is broken too, so they tried it with several fans with no success, so they guess its a problem with the LogicBoard.

Now I get this code from AHT: 4MOT/4/40000002:CPU-0, but I can hear it running, and the Temps are okay too (in °C)


Well another program shows me that the internal HD is at 0.0°C


Here is a handy article on how to decode Apple error codes CNET - How to invoke and interpret the Apple hardware tests

So looking at your AHT error: 4MOT/4/40000002:CPU-0

4MOT- Fan motor

CPU - Of course is the CPU

What is odd here is the error 0 I've always seen some three or four digit error here we see none.

Then we have FanControl showing 0 temp on the HD. I'm wondering if the SMC needs a reset here.

But, before we do that can you tell me how you have the system powered are you using a UPS or a surge suppressor (not a power strip) and have you checked your household power services to make sure Ground is good and you have no power fluctuations. Do you get a lot of lightning storms in your area? If you do have you noted the light flickering or have had power outages?

If any of this holds true you may need to replace your surge suppressor (damaged), repair your power services and/or talk with your power supplier. If you have a UPS you may need to replace the battery or it may not be able to support your system through a power disruption.

Here's a good Apple TN on resetting the SMC Intel-based Macs: Resetting the System Management Controller (SMC) as you can see one of the symptoms of a messed up SMC is the fans running high in the TN.

Lets also check your SMC firmware level and if needed update it. Follow this Apple TN EFI & SMC firmware updates for Intel-based Macs.

Let me know what you discover.

Well I did the SMC Reset, pluged the Mac to another plugbox and I'm not using a UPS or surge suppressor. The power services are good too, ground tested and no fluctuations.

Well I don't know if the reset is done properly, I'm not standing there with a stopwatch. But normally I disconnect my Mac when it's shutted down. So a SMC reset is done all night.

I tried to install the firmware updates but it is said, that they are already installed.

Are you still getting the AHT error when you run it? Is the fan still running at full tilt?

댓글 5개 더보기

댓글 달기
가장 유용한 답변

I had done the same thing when dismantling the iMac 27" Mid 2010 Model, the internal heat sinks where clogged with dust making the iMac run really hot (but strangely all the FANS remained at normal speeds), so as I have done countless times with notebooks I dismantled the unit and removed the main logic board, but in my dismantling when i pulled out the power button cable connector, i must have inadvertently ripped off the SMC resister just above the connector there and this made the CPU FAN report 0rpm which causes the system to run the CPU FAN at maximum speed, I do not know what the correct resistor was but i tested the resister directly above it and it reported as 10k ohm, so i took a guess and soldered on a new SMC 10K Resistor and prayed it would work :) lucky enough it did and now the CPU fan is reporting 950rpm at idle. So I hope this helps, but if anyone knows if the resistor marked (R5797 on the logic board) is 10K or not, I would like to know :)

해당 답변은 도움이 되었습니까?

점수 8

댓글 15개:

Wow! This really helped! I'm using my 27" iMac for school as I study graphic design.

But since a month or so my cpu fan blows at full speed. (I had to take out my logic board to repair a broken internal display connector)

I've done so much this past month: took it to Apples technical service, replaced the fan, took it again to technical service and finally got the news that my logic board had to be replaced for a rough 600 euros (Belgium).

Your post made me search to that resistor and indeed the one you're talking about is broken off.

Could you give me more detail about the replacement part/resistor you used? :)


The resistor I used was a 10K ohm surface mount type (I didnt have the original resistor to test so i tested the resistor above the one that was missing and it read 10k with my multimeter, so i took a educated guess the missing one was also 10k) I then salvaged from some old electronics boards a 10k ohm SMD type resistor that was slightly larger than the original one, but it is so small and tiny you need tweezers and a 0.5mm soldering iron tip and a magnifying glass with light and a very stable hand to solder it back. But after I successfully soldered it back in place, the iMac went back to normal fan speeds :) I hope this helps :)

Resistor is like this one:


I have one of these iMacs and, following your advice, I looked for the resistor and found that I too have a missing one right next to the power button connector. I touched one of those color banded 10kohm resistors to the contacts and immediately got an RPM reading for the CPU fan. The fans turned right down and the computer seemed much happier.

Next step is to have someone more skilled than me place a resistor on the board but this is definitely the culprit.

I took a couple pictures so anyone else with this issue can pin it down. FWIW, the spot was fairly easy to find once I knew it was near the power button connector. Only had to remove the glass, display, and power button cable to find it.

From afar: http://i.imgur.com/8W8SpxR.jpg

Close-up: http://i.imgur.com/hbvNIE3.jpg

Okay so the actual resistor for that is a 47K 1/16W 5% in a 0402 package.It's around $0.10 at places like digikey.com etc. It does control the Fan Tach circuit

Cool! How'd you figure that out?

댓글 10개 더보기

댓글 달기

Hey scallejam, seems to me your L5701 is missing. L5701 is s labelled on the spec as FERR-220-OHM 0402 .

I uploaded image for reference of its continuity points, hope it helps!

Block Image

해당 답변은 도움이 되었습니까?

점수 3

댓글 6개:

You are right! That was the problem, and it's waiting to be solved. However, I sold it to a guy who repairs and sells a week ago, and he has just told me about missing L5701 (%#*@ presbyopia).

What a pitty you didn't pass by before :) but hey, your message will help somebody, I'm sure!

Thanks a lot!

@kylofresh would you be able to upload the same image with continuity points for R5797?

I accidently broke mine of when resetting the power button plug, and now I dont know how to get it back on..

Tried soldering but its still not working. Need magnifying glass. Thanks in advance.

@Jonas I just saw your comment today, almost a month later. Did you get to resolve your issue?

My iMac L5701 is missing also. I was wondering if I buy below it is same one


Thank you @kylofresh! You saved my butt! My old man eyes and shaky hands couldn't handle the original 0402 resistor; Yes it was there. I was able to replace it with a 1001 resistor thanks to your photo! Finally my Mac's fixed!

댓글 1개 더보기

댓글 달기

I can confirm that the fix works.

Got help at my office to mount a "47K 1/16W 5% in a 0402 package" at the place specified in this page.

They said at my office it looked like there where something mounted there before but is now missing.

After mounting the resistor the fan speed return to normal.

해당 답변은 도움이 되었습니까?

점수 2

댓글 2개:

I too accidentally took the small resistor out while trying to upgrade my CPU and the cpu fan run at full throttle.

By the way where did you order the resistor?

I'm so glad i came across this discussion as it is very useful.

Peace!. :)

Just like to add:

You can order the resistor at digi-key

partnumber: RMCF0402JT47K0CT-ND


it cost me $6 total.

댓글 달기

R7460 looks like an empy position, If rpm = 0 then control the fan connector , could be a fake contact of the rotation sensor , slightly pulls the wire into the connector , I have solved this way the problem

해당 답변은 도움이 되었습니까?

점수 1

댓글 1개:

Can give a step or pic how to do it

댓글 달기

Could somebody tell me how to connected the three wire of a Zalman Fan Mate 2 potentiometer with the four wire of the fan?

해당 답변은 도움이 되었습니까?

점수 0

댓글 5개:

You have to try it, there are 3 black cables one is - one is 5+ and one is 12+ the best way is to use the external PSU to find out which is the right one and then mark it. I used the Trial and error.

PSU --> Zalman black and red zalman Input --> CPU fan. Maybe you have to split that Input to the yellow/White one to make the fan move.

But my Fan Mate is getting very hot after a while and now I ise something like this: http://amzn.to/1KPdq6J

PSU @7.5V and fine adjustment with the potentiometer.

Thank you for your reply, I will try. I am waiting delivery of my Zalman Fan Mate 2.

For what is your alternative, this product is not available in Canada. I'm looking for an equivalent.

Well it's something like this: http://bit.ly/1QT89ia maybe you will find something similar in canada.

I finally installed the Zalman Fan Mate 2. It works very well for minimum and maximum speeds. The intermediate speeds are more difficult to adjust. The whole is very satisfying and I have not seen yet exaggerated heat.

I could find in Canada a similar potentiometer to the one you suggested, but I thought 4W was not enough and I was looking for 6W minimum.

Thank you again.

Good luck with that!

댓글 달기

I had done this once, i pulled the wires out the fan plug by mistake, and put them back in the wrong way so the fan span out of control. However i followed the wires round with my thumb from top of fan and managed to get them in the right order. Fan was as quiet as a mouse after that. Don't know if that is your problem but so easy done.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Anybody know what the value of L5701 is? I accidentally ripped the %#*@ pad of the side that goes towards R5797...currently testing (jumping) with kynar and a couple resistors. Thanks.

해당 답변은 도움이 되었습니까?

점수 0

댓글 3개:

Just in case someone else encounters this apple hassle, L5701 has no value...added a 0 ohm resistor from another junked PC board, jumped it with kynar to the corresponding spots (because of ripped pad) and fixed the issue.

You need a steady hand, magnifying glasses, fine tip, voltmeter, experience with tiny resistors and a friend with mac to know where is and not continuity on those resistors in order to accomplish this type of repair. Good luck!

If somebody else finds this post referencing the L5701 and if, like in my case, the contact pad was ripped off along with the component: the Mac can be fixed by running a wire from the CPU fan connector (second pin counting from the top down) directly to the right side of the nearby component 1R5700.

I can confirm that @iphone3ghulp's tip worked fabulously. Thank you for sharing!

댓글 달기

i don't understand, i have change apple hd with another and the fan goes max, after i have installed macs fun control and all ok!

after i have installed another hd (SSD) with ifix kit and change i3 cpu with i7 cpu and the cpu fan go max speed!! i don't know if the r5797 solved my problem or not, how to do? i think that r5797 never installed on my logic board.

i have try to sconnect ssd, but nothing!!

i have change i7 to i3, but nothing

what is happened?

please help me,thanks

해당 답변은 도움이 되었습니까?

점수 0

댓글 8개:

Close-up: http://i.imgur.com/hbvNIE3.jpg

Check if you have missing resistors on that area of your motherboard...that can cause a full speed cpu fan (0 RPM).

thanks to all, I had already checked the missing resistor but my technician says that at that point there has never been .. at this point I will try first to install the kit owc and then I will find someone else who will install the resistor

hi i have installed, owc cable, but nothing!!! cpu fan goes maximum velocity! i will try mount a resistor.......

Hi, after the cpu exchange my cpu fan went maximum velocity. I found this site and - yeah! - I ripped the f***ing L5701! I simply closed the pins with a soldering bridge and everything is OK again. Thanks a lot for your tips here!

He (Michael) used a soldering iron to heat up some solder and join the two pads (where the resistor goes) but, that procedure was specific to the L5701 resistor that was ripped off the board by accident.

Dario, install MacsFanControl (google it), run it, and see if all fan RPM speeds are recognized. If one of them says (0 RPM), post which one does the app refer to.

댓글 3개 더보기

댓글 달기

Looks like I need help with a ripped off part too. Fans are blowing max RPM for CPU fan and I seem to be missing R7460. Any good ideas on what to do to replace it and whether it will fix my CPU fan maxing out?

image attached

Block Image

Update (03/14/2019)

I re-seated the wires and last night the fans behaved with the CPU and power supply temp going all the way to 50+ degrees Celsius. The fans stayed at a rock steady 1000 rpm the whole time. This morning I woke up my iMac and as soon as the CPU temp hit 44 the fan CPU fan went full blast. All the other temps seem normal with ambient in the 20s. I’m really stumped on this one. Should I try reinstalling the OS?

해당 답변은 도움이 되었습니까?

점수 0

댓글 1개:

Any update? I don’t see this R7460 too

댓글 달기

ok that’s excellent - thank you so much. I’ll give that a try.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

I have same problem here (iMac 27 late 2009 Core i7 2.8 GHz), CPU fan at full speed

Long story short, SATA HDD connector at motherboard was broken, I managed to fix it but once it was assembled again, noticed fan problem

I’ve checked resistor R5797 is still in place and it meassures 47k (46.73 aprox) My first thought was about skin sensor, as pins went out of plastic when removed, but iStats says all temperature sensors are fine.

So… what would be the problem? I was really wishing it was a resistor problem, at least there would be something to start up, but now I’m clueless

Block Image

해당 답변은 도움이 되었습니까?

점수 0

댓글 1개:

Your L5701 resistor is missing. It must've of been knocked off

댓글 달기

I have the some issue with my iMac, the cpu fan report 0rpm which causes the system to rum the cpu fan at full speed. I have checked the logic board and the resistor R5797 is missing. Probably I have ripped it off when I have unplugged al the connectors to upgrade the hardware.

Can you tell me the precise attributes of the resistor R5797?

해당 답변은 도움이 되었습니까?

점수 0

댓글 3개:

Not sure of that attributes, but I read somewhere that bridging both pads do the trick. Nothing to lose if you try and tell us

Solved I have welded a new resistor with the following attributes: SMD 0402 47k ohm 63mW ±5% -55÷125°C

I was fixing an 2009 iMac and previous owner knocked off R5797, and since he didn’t know what happened, disconnected the CPU fan because it went ballistic.

Since I already had (someone fix) a similar issue some years ago, I knew exactly what resister was off.

After two nights of soldering under microscope, I ended up just shorting the right resister pad with the below (diagonal) testing pad, with a tiny piece of wire.

Worked perfect.

댓글 달기

귀하의 답변을 추가하세요

[deleted] 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 0

7일 전: 14

30일 전: 77

전체 시간: 58,444