주요 콘텐츠로 건너뛰기

A 35mm FD-mount single-lens reflex camera introduced in April 1984 as the second in Canon's T series.

9 질문 전체 보기

Attempting to take a shot, but buzzes, followed by beeping.

Just picked up a Canon T70 from a thrift store, and wanted to test it out. When I initially checked to see if it would take shots, it just buzzed. After the buzzing finished, the camera would beep repeatedly.

The battery level appears to be fine, although I have not had the chance to replace them. Looking online, I heard that it could be that the motor has seized up.

Does anyone have any experience opening up one of these cameras and adjusting/lubing the gears? Any tips?

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 2
댓글 달기

답변 2개

Same problem you find answer?

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Have a working one. After a long time in storage, motor sounded like it was agonizing to advance the film, but after 2-3 rolls of films it went back to the happy sound I remembered from its youth. So motor seizing up could be an issue.

I also have another T70 I just got for future use as spares, same problem as nuget48. I downloaded the service manual (google for it, its freely available) that shows how to get to the motor. I will first try to move things from the outside - nudge the rubber take up reel to see if I can free anything, and if its not helpful will try to get to the motor when I have some free time, I will let you know if the problem was solved.

Another thought: since the shutter did not operate as well, it could be stuck on that. maybe I should first check the shutter.

anyway I will have something to play with :-)

해당 답변은 도움이 되었습니까?

점수 0

댓글 1개:

I know it has been over six years, but I, and many others have this exact issue. Could you update us on the spares camera?

댓글 달기

귀하의 답변을 추가하세요

nuget48 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 4

7일 전: 8

30일 전: 58

전체 시간: 2,934