주요 콘텐츠로 건너뛰기

The PowerShot SD850 IS Digital ELPH is a digital camera with a 8.0 Megapixel CCD, and a 4x Optical Zoom. The item was released in May of 2007.

8 질문 전체 보기

How do I fix my disconnected lens?

My camera lens is disconnected from the actual position. How do I fix it?

답변되었습니다! 답변 보기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 34
댓글 2개

I stuck a card and tried to gently flick out anything that might've been in there like sand or dust but nothing came out. I was discouraged but I kept doing it and I actually tried to lighting bang the camera on he table while opening the camera and it worked! Moral of the story there is probably dust but it won't get out the first time. Try it a couple of times and bang it very gently on the table. Good luck!

the lens is crooked and does not take pictures

댓글 달기

답변 8개

선택된 답변

we had this question in the past for a few powershot models

i quote an old answer:


there are many ways to get it work again (at least to try to)

the best way is this:

Turn off the camera. Place it on the back with the lens facing up and take a look at the spacing between the lens and the lens housing. If you notice that the gap is not even all the way around the lens, the problem should be easy to fix. This type of a problem usually occurs if the camera was dropped while the lens was extended. Simply - VERY GENTLY - press down the lens on the side where the gap is the biggest. You should hear a “click” as it pops back into place. Try powering the camera back on.

i've found it on the net, here is the original text - if that won't help - go to the source page and read about the other options


it's for a different model, but they have normally the same problems

good luck

해당 답변은 도움이 되었습니까?

점수 25

댓글 27개:

+ works for me

This Worked Fine for me "markus weiher" . Thank you for your Help :)

It worked! I jiggled and pushed the lense housing and smacked the camera lightly on the tile floor and it now works!!! I had a powershot do the same thing to me 2 years ago, so I got that out and tried the process out on that one too, but it didn't work on the 2nd camera. The only difference between the issues of both cameras is that with the older camera, I DID accidentally bang it on something at the zoo while the lense was open. The camera that your advice worked on was never banged against anything. I took a pic of the dog and put the camera back into the bag 2 days ago. It was fine. What did happen with the newer one is that, coincidentally (or not?), the sd card is now corrupted. Did the SD card break the camera or vise/versa? I can't get my son's kodak, the (fixed) canon, or any of my 3 computers to detect the SD card which also worked fine 2 days ago.

Thank you so much, I was getting worried it was broken forever. It worked really well for me.

Thank you!!! I thought my camera was done for and literally followed these instructions exactly and it was fixed in under 10 seconds!!!!!!!!!

댓글 22개 더보기

댓글 달기

I used my Dyson vacuum cleaner to suck the lens while I booted it. Lens popped right out (instead of beeping and saying "lens error") and functioned as normal. Worked a charm!!

해당 답변은 도움이 되었습니까?

점수 7

댓글 1개:

I tried that and it did not work

댓글 달기

I just used a very very thin (almost paper thin) rewards card (anna's linens) and gently circled the the outer layer (removing grime) and it popped out! fixed! yay!

해당 답변은 도움이 되었습니까?

점수 4

댓글 1개:

Thanks for this tip. It worked and while I still had the thin card around the lens I turned the camera on in hopes that I could also help pry the lens up so that it was level all the way around. It worked! My camera was a Canon Pureshot ELPH300HS. I thought the camera was a goner after the store said it wasn't worth repairing and it was past the extended warranty on it. I decided that it was time to try one last fix on my own. Thanks for all the advice from this forum.

댓글 달기

Lens errors are fairly common. Usually it's sand or grit interfering with the lens extension mechanism. Or the camera's been dropped with the lens extended. Or the camera has been powered on, but the lens had been blocked preventing its extension. Or the battery ran down with the lens extended ...

Unfortunately, many cameras that fall prey to this can only be corrected by professional repair. But, here are some things that you can do that may correct it, without even opening the camera. They only seem to work for less than 40% of the lens errors, but if the camera is out of warranty, they're worth a try.

해당 답변은 도움이 되었습니까?

점수 2
댓글 달기

Well, I was really upset when my beloved Canon PS SX10IS gave me a 'Lens Error, Restart Camera' message. Then it shut off, and I couldn't even access the 'review' feature to see the photos I had just taken! I replaced the batteries, but that didn't fix it. In looking at the lens carefully as it was trying to open, I noticed some white caulky-like material peeking out from under the outer lens ring. In fiddling with it, the outer ring came off. I could see that the caulk was like a glue, holding that plastic ring in place. The camera worked fine w/o the ring, opening, focusing, and shooting. The outer plastic ring was only acting as a protection for the camera's 'insides' when it was fully extended in zoom position. Knowing how much the fix is, I decided to try to fix it myself. I removed the caulk that seemed to be in excess, left what I could and snapped the ring back in place, paying attention to fit the appropriate parts together. It's now firmly in place and the camera works again perfectly. The lens extenstion/zoom was catching on the loose caulk.

I tend to carry the camera by the lens. Am sure that this is what caused it to loosen from the caulk.

Good Luck!

해당 답변은 도움이 되었습니까?

점수 1
댓글 달기

It may be possible to insert a feeler gauge or better yet crisp flexible plastic in around the three parts of the lens barrel. Maybe that will let you get under whatever gigantic clod of grit is wedging the lens tight. The smallest, inner ring(for the part of the lens that extends out the farthest from the body) is only 8-10mm deep and the next two are deeper.

After trying that sort of thing, as well as general beating and assorted ways of turning on multiple buttons etc our SD850IS still wouldn't open. We pulled the outer ring off by slipping a feeler gauge in and around it to release the adhesive. Twisting the next 'cap-ring' (round with the semi rectangular opening in the center) counterclockwise released it and exposed the two lens covering flaps. I took one flap out to have an intact one left to compare too. While I did take them out, what worked was prying the lens out by one of the little bosses, the nub, that held the cap-ring in. It responded to a moderate pull.

Maybe the speck I saw on the barrel was the culprit. In any case I wiped it clean and reinstalled the battery. It has now cycled properly with the battery reinstalled and is working again.

p.s. the springs on this model are different than what I saw on the article about the A1000. The spring wraps around the pivot post. Before pushing the flap all the way down on the pivot post you will want to catch one end of the spring arm on the post that drives the flaps to open and close. You may hold the end of the spring with a toothpickk to hook it over the post or you may catch the post by twisting the flap a millimeter extra before pushing it all the way down on the pivot post.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Had a lens error on my Canon PowerShot SD1400 IS. The lens would not retract I saw a bunch of fixes online that did not work. Finally I started fooling around with buttons b/c like all electronics sometimes using combinations of buttons help clear the issue. Not sure if this will work for everyone but worked great for me. I charged battery fully, reseated (take out and put in) the battery and SD card. Then I turned it on again, when the error message popped up I held down the play button that looks like a triangle in a square and the Function set button at the same time and the lens immediately retracted. Then I restarted the camera and it worked properly. Hope this fix helps other's.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

September 10, 2016

Canon PowerShot SD630 DSigital ELPH

Lens would not retact after dropping it while in use. There was a visual dent on the outer lens,

After performimg steps 1 through 7, minor force was applided to the outside of the lens while turning on the power, it popped into place and the lens retracted properly.

Tested it a few times and problem has not occurred.

Thanks for advise

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

pragathi 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 1

7일 전: 5

30일 전: 42

전체 시간: 238,951