Water spill -partial recovery

Spilled 1/2 glass of carbonated water on my keyboard. MBA was on and plugged in. Screen went off immediately up on spill. Quickly flipped it over and used paper towels to absorb water. Left upside down with fresh paper towel in place and lightly closed lid to depress keys and allow water to drain. Placed in sun for several hours over two days replacing paper towels several times. On third day tried starting-no luck. Plugged in charger-no luck. Green light not on (checked charger on another MAC-working). On 4th day MBA was sitting on my desk and I heard a chime! Opened lid and normal login screen appeared asking for password. Keyboard completely dead (not a single key would populate login box). Back-light on. Mouse, using track pad, working. Selected shutdown and MBA shutdown then restarted again on its own. Selected sleep and MBA went to sleep then woke up on its own. Shut lid and observed back-light go off. MBA always back on login screen when lid opened. Battery went from 60% to 50% over a day. Opened back cover, unplugged battery then I/O board cable. Sprayed Radio Shack electronics cleaner on contacts of I/O cable connectors but not on battery connectors. Let dry. Reconnected I/O connectors then battery connector. Replaced cover. Now MBA completely dead! No self start and all keys still appear dead. No back-light.

Reviewed info on this site and checked 3A32V fuse after disconnecting battery. tested good. Connected battery and tried jumping on/off pads. Nothing.

Ordered I/O board, I/O board cable , battery, and new keyboard with extra screws & rivets. Have "P" & "T" torque head screwdrivers. Waiting for parts and plan on replacing the keyboard then the I/O board & cable.

Assumptions:

*Logic board is OK as unit self-started to login screen

*keyboard and/or keyboard connector likely damaged

*I/O board and/or connectors likely damaged

*3A 32V fuse OK

*track-pad OK

*display OK

Questions:

*What are the likely components I need to change?

*What besides the I/O board would prevent the charger from showing a green light?(also tried disconnecting the battery and plugging in charger but no light)

*What would cause the MBA to self start and keep restating even when shut down?

*What would cause the MBA to stop responding after the I/O cable connectors were cleaned and the battery connector unplugged then reconnected?

  • any other fuses besides the 3A32V?
  • What are the pin assignments on the charger mag connector and the battery connector? Would like to verify power coming from both.
  • Any other power points worth testing to isolate failed component?
  • Possible the battery is now discharged and this is why it won't start anymore. *How to charge the battery? Other MBA is a 13" and I don't want to open up!

Appreciate any suggestions and help. Great site!

Jim

Update (09/15/2015)

OK, removed processor board and cleaned it with alcohol. Did the same for the I/O board. Reassembled and tested without new battery connected, Mag connector plugged in. Green light! Held down power key and system booted to login screen with chime. Trackpad working but still no keyboard input. Tried all keys. No luck. Plugged in new battery and restarted. Battery showing 87% and charging. Mag light went yellow.

Disassembled and replaced keyboard. Reassembled. Booted OK but still no keyboard input of any kind except on/off key. Backlight working. Held down option key and restarted. Did not give option to boot to bootcamp partition. Don't have a remote keyboard or I would try that.

Almost there! Keyboard connector? Suggestions?

Thx,

Jim

이 질문에 답하세요 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0

댓글:

You want to remove your board and clean it properly. Stay away from contact cleaner. Use either isopropyl alcohol or an ultrasonic cleaner. Have you checked for any damaged components?

Thanks for the advice on the cleaner fluid, I'll use isopropyl alcohol.

Can't see any damaged components but haven't removed anything yet- waiting for parts to arrive. Really no signs of water damage on the bottom side so I suspect most of the water sat on the keyboard. Because every key is not working its most likely a connector problem but then this connector is near the track-pad from what I've read and the track-pad was working so maybe not. Anything common to the keyboard connection and the I/O board?

Jim

How does it work with an external keyboard?

Can now log in w/ USB KB and everything except the new KB is working. Update is that I got the new KB to generate an OP by removing the trackpad and cleaning the KB connector and ribbon cable ends. I was still unable to login until I used a USB KB.

I typed using the KB and the KB was generating a strange character set with all keys working. I activated the virtual KB and observed that the "Shift" & Option" keys are activated (grey). When I activate these keys on the VKB I get the exact character set key for key. All 4 keys appear to be mechanically free. So, either they are somehow stuck internally or there is still a short in the ribbon cable/connectors. I suspect the latter.

I plan to go back in and re-clean the cable & connectors. I did not touch the ribbon cables and connectors on either side of the KB connector on the trackpad. The trackpad is working fine so these should be OK.

Jim

의견 추가하세요