Very strange problem reading disks?

I've had a Gamecube for roughly 9 years, and there's never been a problem with it. However, I stopped playing 3 years ago because I bought a Wii. Now that my Wii is permanently damaged, I dusted off my old Gamecube so I could continue to play my GC games.

Ok, so yesterday, I installed it, and when I started it, it had a "No Disc" error. I researched and decided to clean the laser lens a bit with a qtip, but I tried again, and now it gave a "Disc read error". Then I cleaned up the disc, and tried again, and it worked, and had no problems playing. As such, I concluded that it was that the laser was dirty and the disc was also.

The problem starts today. I turn on the GC, and it gives again the "No Disc" error. Noting that it was strange, I did the same things I did yesterday. Then I started the GC again, but this time, it gave a "There has been an error. Please turn off the Nintendo Gamecube" message. The strangest thing about this, is that when the message appeared, I could clearly hear the disc spinning like it was working normally.

So, I really don't know what to do, and would appreciate any help.

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 0
댓글 달기