Skip to main content

Announced January, 2014 Released May, 2014 Identified by the model numbers: D5303 D5306 D5316 6.0 Inch Screen.

6 질문 전체 보기

Why is the backlight on but the screen isn't showing color?

I just disassembled and assembled a Sony Xperia T2 Ultra D5316 after I dropped it and broke the digitizer. I let it charge for an hour after the repair, and when I turned it on, the screen's backlight lit up but no colors are showing. The phone has been laying disassembled for around 6-7 months. I tried putting another screen in it before this but got the same result. When I use the unlock gesture to enter my password, I get feedback from the vibration motor, telling me that the digitizer is working and I am able to interact with the phone without any color from the display. If everything was working I would be seeing the numbers and hearing the accompanying vibration when I tap them. But I can't see the numbers or anything for that matter. So I need some suggestions on what I should try to do in order to troubleshoot or if I should describe my problem in an easier way.

Answer this question I have this problem too

Is this a good question?

점수 0

댓글:

Check the LCD flex cable. This cable appears to be very fragile since the first screen went faulty due to unknown reasons. The second one still works but there is a slight rip in the LCD cable, luckily the display still works but I used super glue in the slight rip in the flex cable to stop it from ripping more.

의 답변

Alright. Do you mean the LCD cable connecting the display to the motherboard (also connecting the volume, power, and camera buttons) or the cable coming directly off of the display?

의 답변

Cable coming directly off the display, there are two spots that can cut very easily. The motherboard cable is OK right? because I ended up replacing the phone for a customer when I ripped the motherboard cable.

의 답변

I think the motherboard cable is OK because the screen responded "normally" after I put it back in. I still think it's the motherboard cable issue because I don't believe I damaged the LCD cable (let's call it that). But I may have ripped the motherboard cable when I tried to take out that cable. When I tried to pry it off right where the LCD cable plugs in, I gave it a pretty good tug and may have done some damage. I don't know for sure.

의 답변

Well if it is motherboard cable. You are probably out of luck. I couldn't find anyone that could connect the motherboard cable to the logic board.

의 답변

코멘트 추가

안드로이드 수리 키트

새 스크린 혹은 배터리는 단 하나의 키트로 충분합니다.

지금 장보기

안드로이드 수리 키트

새 스크린 혹은 배터리는 단 하나의 키트로 충분합니다.

지금 장보기

1개의 답변

Most Helpful Answer

I think you have installed some unwanted software in your Phone so you have to rest your phone otherwise go to the Services center.

Was this answer helpful?

점수 3

댓글:

Never thought of that. Interesting. Would like to hear from OP if that solved the problem.

의 답변

What's OP? And what do you mean by connect the motherboard cable to the logic board? And what's resting your phone? Sorry for all the questions, just want to clarify things. And I don't think it's the unwanted software but that's a possibility.

의 답변

Hi,

I think by OP he means Original Poster i.e you. and presume it is a typo and rest may mean reset. We 'll have to wait on an answer to the motherboard cable question.

의 답변

I don't think that's the problem, I think it's a display cable issue, I'm just going to send it in and see what Sony says is the problem. Please reply if you have more advice. Sorry I haven't responded as well. Been busy. And I'm just going to mail it to the Service Center like you recommended.

의 답변

Haven't made any progress on this whatsoever...

의 답변

코멘트 추가

Add your answer

Jonathan Simon will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 293