Nintendo Game Boy Advance, released in 2001. Repair requires only common tools and no heat.

27 질문 전체 보기

No power, clean battery terminals, F1 fuse works

I just recently got in two game boy advance units (AGB-001) from Japan and off eBay. Both units will not power on and I've tested good, working batteries. I've also opened up both systems and checked the F1 fuse located right next to the NEG power terminal. The fuse appears to be working properly. I've used a multimeter on continuity mode to verify that it's giving the appropriate reading.

The PCB also appears to be spotless. I've looked over the board, there is no battery corrosion. There doesn't appear to be any bad traces or burnt out or damaged components. Initially, I thought I saw the 2nd device flicker green and red in the power LED but I haven't seen anything since I initially tried turning the game systems on.

The only thing I could think is that the power switch might be bad. I'm not entirely sure how to test the power switch to see if it's working properly.

Does anyone have any idea what might be stopping this unit from powering on?

Thanks for any advice you could give!

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1
의견 추가하세요

US$100 이상 또는 Pro Tech Toolkit을 포함한 모든 주문의 배송은 무료입니다!

상점 둘러보기

1개의 답변

선택된 해법

So, I finally have an answer to my own question! Turns out it was a bad power switch, well not "bad" but it needed some cleaning.

I got two GBA units in from Japan with the same problem, great battery terminals, working fuse but no power at all when switched on. I did notice that the blue unit would flicker power when I switched it on and off. So I slowly moved the power switch and at about 55% on, the unit would power up and the games would play.

That got me curious, so I took the pink unit (since it wasn't working at all) and opened up the power switch. You can see what it looks like here. It's actually a pretty simple design. There are three metal contacts and the slider has two very tiny metal prongs that contact only two of the three pads at any time. In the provided picture, inside the slider, you'll see those three metal pads and they look very dingy. I took a small piece of 600 grit wet-dry sandpaper and cleaned up those three areas. I also lightly sanded the slider as well.

When I reassembled the pink unit, it powered on like a champion! I was very happy to have found the issue and jumped right onto the blue one and gave it the same treatment. Sure enough, the blue powers on with no issues at all. Both units work great after I gave it my typical cleaning and further refurbishing. I almost want to keep one of them just for the satisfaction of solving this mystery.

해당 답변은 도움이 되었습니까?

점수 5
의견 추가하세요

귀하의 답변을 추가하십시오

Andrew Fillhart 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 2

지난 7일: 15

지난 30일: 98

전체 시간: 1,789