주요 콘텐츠로 건너뛰기

A1418 / EMC 3069 / 2017 / 3.0 GHz quad-core i5, 3.4 GHz quad-core i5 또는 3.6 GHz quad-core i7 프로세서. 2017년 6월 8일 출시.

59 질문 전체 보기

USB-C ports are no longer working

I upgraded my computer to 32 GB of RAM and attempted to add a second SATA hard drive. Now the USB-C ports don't seem to work (a second monitor that was working before the upgrade is no longer working). Every other port is working. Are there any USB-C connectors that plug into the logic board somewhere? Any idea what could have gone wrong here? Neither port is working.

해당 질문 답변하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 2
의견 추가하세요

6개의 답변

가장 유용한 답변

My iMac (21.5 inch 2017 model, 3.4 GHz) had a fusion drive, and I upgraded the ram to 32 GB and replaced the 1 TB drive with a 500 GB SSD. Using Apple's instructions for fixing a fusion drive (https://support.apple.com/en-us/HT207584), I merged the "blade" drive and the SSD into a new fusion drive. I then restored from a Time-machine backup, and reset the PRAM and SMC.

The USB-C ports did not work with my external display when I used a USB-C to HDMI adapter and cable that had worked before, but when I tried another adapter, the problem was resolved. Both adapters were supposedly exactly same, as I had purchased one for my iMac and one for my laptop (https://www.amazon.ca/ICZI-Aluminum-Thun...), but only one worked. The adapter and cable that you are using to attach to your monitor may be the issue.

해당 답변은 도움이 되었습니까?

점수 1

댓글:

Is the adapter you listed via amazon the one that works? I'm experiencing the same issue after only installing upgraded RAM. Everything else is the same.

의 답변

if your USB-C ports are not working then no adaptor will work. I tired 3 different adaptors even form Apple nothing worked. Was it working before up upgraded? maybe try a different type of RAM.

의 답변

의견 추가하세요

In my case, the motherboard was badly seated, 3 mm is enough to make the ports fail because the connectors doesn’t go all the way in and it’s very hard to see this problem just by using your eyes, take it apart and take a look at the ports assembly on your MB, you’ll notice a small bump/ball/thing in the middle, this bump has to fit into the iMac ‘case’, you can feel it when seating the MB on the case if you do it right

해당 답변은 도움이 되었습니까?

점수 1
의견 추가하세요

It sounds like you may have gotten the wrong cable or a bad one.

Presently I have not been able to find a source for the 21.5" iMac (2017) SATA cable. The only cable I have found is the the older 2015 model: HDD Combo Cable, iMac 21.5" Late 2015 - Apple P/N 923-00565. It's possible this one would work but then again I don't know of anyone trying yet as the system is so new.

Where did you get your cable and its P/N?

I would recommend disconnecting it from the logic board and then retesting the USB-C ports to see if they are now working. Let us know what you find.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

I'm having the same issue.

It's weird, it was working but not it's not. (I just brought a brand new iMac 21.5")

Also, I brought a USB-C to USB 3.0 multi adaptor, the both worked for 1-2 days then stopped.

I'm still seeking the answer.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Same issue here. I upgraded my 2017 21.5 iMac to 32 GB RAM. Everything fit back into place and works like a charm… except the USB-C ports. I’ve tried all the USB-C cables and adapters I can find. No luck. Do people think this is a problem with the RAM, or is it more likely that I somehow damaged the USB-C ports?

Update (01/15/2019)

I ended up solving the issue. I think there was probably a slight misalignment between the port and the case. When I looked at my computer I saw that it looked a little off. So I stuck a USB-C in and just put pressure on it toward the direction I thought it needed to go. After a few seconds of pressure, I heard a “snap” and then the port started working. I was definitely worried about breaking it, but I figured I had nothing to lose so I just went for it.

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

I am experiencing the same issue. I upgraded my Imac to 32GB of ram and the usb-c port stopped working. I use practically every combination of new cables to connect to my dual monitor and no luck. Only to find out that the c-port is not functioning any longer. I wonder how I can address this issue.

해당 답변은 도움이 되었습니까?

점수 0

댓글:

Also, the Ram that I used was from macsales.com and the brand is OWC

의 답변

의견 추가하세요

귀하의 답변을 추가하십시오

jasontpkoebler 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 2

지난 7일: 5

지난 30일: 37

전체 시간: 657