주요 콘텐츠로 건너뛰기

The DC56 is a cordless handheld vacuum designed and created by Dyson. This page includes repair and troubleshooting guides for many issues that could happen to a DC56.

5 질문 전체 보기

Why does my Dyson stop working every 3-5 seconds

We have a Dyson DC45. It shuts off (stops working) every 3-5 seconds. Can this be fixed, by myself or at a repair centre?

The Dyson DC 45 ( I have shown DC56 here as it appears similar to the DC45) stops every 3-5 seconds when in use. The following is a more detailed series of the events which occur.

The Dyson is fully charged, when starting use with the brush head attachment, stops working after about 10 seconds of use.

We turn it on using the trigger starter. It stops again after about 3 seconds. We release the trigger and press it again. It starts and runs for approximately 3 seconds, then stops again. The sequence of restarting is repetitive until we give up in frustration.

Is there a "home fixable solution" or must it be taken to a repair shop? If so, where in the Toronto area can it be taken.

Thank you

이 질문에 답하기 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 14

댓글:

My disown work 3 or 5 seconds and stop working can I do anything L thank you

You need to remove the cone shaped filter ‘washing it alone isn’t good enough you need to remove the filter at the thick end there are 2 small clips that you can push in with a blunt knife to remove the filter sock from the frame!! Once you have done this you will see a large amount of dirt trapped in the filter frame remove the dirt wash and dry the filter sock preferably overnight clip the filter back together put it back in the machine and bobs your uncle

I have this same problem. Looked for this cone shaped filter and 2 clips but cant find it. Any help would be great.

Mine doesn’t have clips as such - but it has 3 little horizontal slots a few mm wide, that I depressed with the blunt end of a screwdriver. That was enough to pop the frame out of the sock thing, There was a plug of hair and dirt about an inch long and wide, jammed into the bottom/narrowest part of the cone!

brilliant it worked,why did I spend an hour on the phone talking to dyson and they couldnt resolve it

14에 댓글 더 나타내기

댓글 달기

답변 12개

가장 유용한 답변

I assume the battery is dead. Try a new one - you can get them everywhere online.

Pay attention to choose the right one as Dysons have quite different connectors.

해당 답변은 도움이 되었습니까?

점수 2

댓글:

Have the same problem - changed the battery and worked properly for a little while and then started to do the same thing again.

After mine stops I put it back in the charger for a couple of minutes than it works find. But would like it to just work. Any other suggestion ??

Try to open the cone shaped filter, as John suggested above. I did this just now and found a massive plug of hair and dirt wedged into the bottom end of the cone, that I would never have seen if I hadn’t disassembled it.

I became suspicious that the filter was the issue with my stop/start Dyskn, when I took the filter out initially and realised that the machine worked fine if the filter wasn’t in.

Do it - it’ll work!

댓글 달기

There is a tab on the filter that wears down and stops it from running for more than a few seconds. Here's a video on how to check for that issue:

https://www.youtube.com/watch?v=9IUZ_Gol...

해당 답변은 도움이 되었습니까?

점수 2
댓글 달기

Had the same problem. Charged fine and then stopped after 10 seconds. This isn’t a filter issue, it means the battery is dead. Bought a replacement on eBay for $45, good as new

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

I have a similar problem. When I pull the trigger, it continues to work but the brush head stops after a second. I’ve cleaned it thoroughly and it’s completely charged. One thing to point out is that when I remove the brush head and pull the trigger, it continues to spin without a problem. I just can’t figure out why it won’t continue to roll with the brush head on. FYI- I’m not talking about taking the head attachment off. I’m talking about tanking the brush roll off itself leaving the mechanical parts of the brush head attachment assembled.

해당 답변은 도움이 되었습니까?

점수 0

댓글:

I have had before its the stick attachment apparently it has sensors in it so may need a new stick part

Same issues With brush out it works fine. Seems like a lot of resistance in brush drive- cleaned out hair I found around the drive wheel and shot some silicone lube into housing and the cut outs were gone. If it happens again I’ll pull apart the housing on the head and put some lithium grease inside drive side and see if there is any other debris retarding rotation

댓글 달기

Solved this 3 years ago with a new battery and I’ve ordered another. I’ll clean the octopus legs just in case but sure it’s the battery.

Ive no complaints with 2 to 3 years Per battery, just wish Dyson let people know. The on - off quick cycles are confusing and I’m sure many have ditched their Dysons in frustration.

i fix it when my wife says it’s broken. Doesn’t slow down like battery power tools.

My wife loves the vacuum.

해당 답변은 도움이 되었습니까?

점수 0

댓글:

90% chance you just need a new battery!

댓글 달기

https://www.youtube.com/watch?v=p3DgP1ci...

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Had the same problem on 2 others. A recent post outlined a correction process by taking out the long tube filter, pressing the side holders back to release the cloth portion, and cleaning what debris might be in the bottom of the inside of the cloth portion of the filter… Brilliant on someone’s part!!

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

I had this problem too, and followed John Metrac’s advice about thoroughly cleaning the cone shaped filter. Sure enough, the filter was chocablock with dog hairs which I had to tweezer out! I had religiously regularly rinsed the filter under running water as advised in the manual, but never thought to investigate further. There was a whole border collie in there! Thanks John

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

I disengaged the long shaft and a green strong plant straw stuck in there. I pulled it out and it fixed the issue. Btw answers in this post were helpful!

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

Check the filter not the problem

Removed battery steal times and reinstalled works fine now

I think contacts on battery better now

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

What do you mean by battery steal times?

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

If all else fails remove the brush from your sweeper head and spray WD-40 into the drive mechanism for about 5 seconds using the plastic straw provided. This worked for me.

해당 답변은 도움이 되었습니까?

점수 0
댓글 달기

귀하의 답변을 추가하세요

Wally Turner 님은 대단히 고마워 할 것입니다.
조회 통계:

24 시간 전: 34

7일 전: 269

30일 전: 1,389

전체 시간: 123,628