Skip to main content

Apple의 MacBook Air 13" 2015년 5월 업데이트에는 5 세대 Intel Core i5 및 i7 프로세서가 성능과 배터리 수명을 약간 향상시켰습니다.

271 질문 전체 보기

MacBook Air only boots to Linux

My wife spilled some water on her MacBook Air (early-2015) a few weeks ago. This killed the battery, but after letting it dry out I found the machine still powers up. However, it gets stuck during boot on the black screen with the Apple logo and progress bar. The progress bar eventually reaches the end, but remains stuck at this point, even after 24 hours.

I was able to boot from a Ubuntu usb and have installed Ubuntu, which boots very quickly and with no problem. However, if I try to boot from a macOS USB, I have the same problem and get stuck with the progress bar. I've also borrowed a friends MacBook Air SSD and put it in the water damaged Air, but still had the same problem - stuck on the progress bar.

Except for the battery, the machine seems to be working well with Ubuntu but not with macOS - any ideas why this is the case and what I can do about it?

Thanks in advance.

답변되었습니다! View the answer 저도 같은 문제를 겪고 있습니다

좋은 질문 입니까?

점수 1

댓글:

Thanks for your advice. No luck with booting to Disk Utilities or the repair partition, I have the same problem with the stuck loading progress bar.

I feel like it is not the SSD, as I've swapped it out for another working one and still had the same problem.

Any idea why I can boot to Linux but not macOS?

의 답변

의견 추가하세요

아이폰 배터리 수리 키트

Only $29.99

Buy Now

아이폰 배터리 수리 키트

Only $29.99

Buy Now

3개의 답변

선택된 해법

Try opening from the recovery partition by holding down the Option key on start up and selecting it. Then rune Disk Utilities. That fail do the same but run the reinstall from the repair partition.

해당 답변은 도움이 되었습니까?

점수 1
의견 추가하세요

Take out the SSD of the water damaged Macbook Air. Use it as an external device using a adapter (can be found on eBay, amazon). Then Re-Install MacOS and hopefully everything will work again. HOPEFULLY YOU HAVE A BACKUP BECAUSE YOU WILL NEED TO ERASE THE DISK!

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

Hello Nav,

I wonder if you solved that situation with your Mac because I am facing the same situation.

I suspected RAM memory failure so I run MemTest86+ and Apple Diagnostics holding the "D" key when powering on the MacBook air, all with OK results.

Running Ubuntu 18.4 from USB and installing it is okay. All devices and options seem to work fine but the Factime Camera for which I believe there are not built in drivers for yet.

Nevertheless, the Mac will load the progress bar completely but stay in a loopback that can be seen with the verbose option (holding Command + V keys while powering on).

I tried creating different Maverick, Sierra and High Sierra USB boot disks from 8 to 32GB unsuccessfully and always with the same result: getting stuck once the progress bar has reached the end.

Still struggling with after three working days with no other option than using Ubuntu 18.4 so far without the camera but I need it for Skype, so too bad.

Thank you and with kind regards from Spain!

Actualización (18/06/18)

Hello,

Finally I had to open the MacBook Air after reading some information about a sensor that could be failing and found some corrosion on the PCB, most likely caused by a small spill.

After cleaning the board it's up and running again.

May this help others,

Block Image

해당 답변은 도움이 되었습니까?

점수 0
의견 추가하세요

귀하의 답변을 추가하십시오

Nav 가/이 대단히 고마워 할 것입니다.
조회 통계:

지난 24시간: 0

지난 7일: 1

지난 30일: 9

전체 시간: 369